aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-rapidjson/disable-c-cxx-flag-march.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-16 02:35:06 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-16 02:35:06 +0200
commit6fa07041d845d0c398c70179576f50782765027a (patch)
treee6bdd9fa30668b56042303a03a9e4080a8f9e343 /community/lua-rapidjson/disable-c-cxx-flag-march.patch
parent4c0838dd9ec06e7a23c4b4fe6b40872e39ffa476 (diff)
downloadaports-6fa07041d845d0c398c70179576f50782765027a.tar.bz2
aports-6fa07041d845d0c398c70179576f50782765027a.tar.xz
community/lua-rapidjson: move from testing
Diffstat (limited to 'community/lua-rapidjson/disable-c-cxx-flag-march.patch')
-rw-r--r--community/lua-rapidjson/disable-c-cxx-flag-march.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/lua-rapidjson/disable-c-cxx-flag-march.patch b/community/lua-rapidjson/disable-c-cxx-flag-march.patch
new file mode 100644
index 0000000000..eb9a8d900d
--- /dev/null
+++ b/community/lua-rapidjson/disable-c-cxx-flag-march.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,8 +33,8 @@
+ set(PLAT "linux")
+ set(LINK_FLAGS "-shared")
+ endif(APPLE)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall -fPIC -march=native")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -Wall -fPIC -march=native")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall -fPIC")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -Wall -fPIC")
+ else(UNIX)
+ if(WIN32)
+ set(PLAT "win32")