aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-toml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-19 18:40:51 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-19 18:41:28 +0200
commit59402ca505e371e3054bb46f6c416692c6c4a01f (patch)
treea8e57da90831a99496d5f6199ce06ec268f0cc10 /community/lua-toml
parentbe904e34b5a05ed8d2c9530668f58b4f812c6a9a (diff)
downloadaports-59402ca505e371e3054bb46f6c416692c6c4a01f.tar.bz2
aports-59402ca505e371e3054bb46f6c416692c6c4a01f.tar.xz
community/lua-toml: upgrade to 1.0.1
Diffstat (limited to 'community/lua-toml')
-rw-r--r--community/lua-toml/APKBUILD10
-rw-r--r--community/lua-toml/fix-decode-arrays-and-include-testcase.patch50
2 files changed, 4 insertions, 56 deletions
diff --git a/community/lua-toml/APKBUILD b/community/lua-toml/APKBUILD
index 9a7b60b907..5b13707849 100644
--- a/community/lua-toml/APKBUILD
+++ b/community/lua-toml/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-toml
-pkgver=1.0
-pkgrel=6
+pkgver=1.0.1
+pkgrel=0
pkgdesc="TOML decoder/encoder for Lua"
url="https://github.com/jonstoler/lua-toml"
arch="noarch"
license="Happy"
depends=""
checkdepends="lua-busted"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jonstoler/$pkgname/archive/v$pkgver.tar.gz
- fix-decode-arrays-and-include-testcase.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jonstoler/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
# luajit is not available for selected arches
@@ -52,5 +51,4 @@ _subpackage() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
-sha512sums="f04ed6f26f47d6492c7a21c310da09b1091476724022c32b81a5492713340a4571bc04c51f34dded73f4f1cf1085dbe08e280356b0f1fa88ef0efefd0685c77e lua-toml-1.0.tar.gz
-8f09e578ef3e7bcc35316ca290e21a47b2d62b439a06228c7e6dcef14e3306800aa44d8b4d70ff2e1cf17211bf7e585423bb4fcd9edb4131076532d4bf5b0640 fix-decode-arrays-and-include-testcase.patch"
+sha512sums="84b8187e24e3e03b31bd9662faceaf6e59e4f15ad63d17a077ed158ee73710297be4ee0d1e503c2d06304bbca100bcf6ff0b92ef58d7accd834e014ac4972add lua-toml-1.0.1.tar.gz"
diff --git a/community/lua-toml/fix-decode-arrays-and-include-testcase.patch b/community/lua-toml/fix-decode-arrays-and-include-testcase.patch
deleted file mode 100644
index 0409f39ee1..0000000000
--- a/community/lua-toml/fix-decode-arrays-and-include-testcase.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From d77cbb5f94bb8fbaa8d589573de20ce120765055 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 14 Jun 2017 11:23:32 +0200
-Subject: [PATCH 1/2] add test case for issue #12
-
----
- spec/encode_spec.lua | 11 +++++++++++
- 1 file changed, 11 insertions(+)
- create mode 100644 spec/encode_spec.lua
-
-diff --git a/spec/encode_spec.lua b/spec/encode_spec.lua
-new file mode 100644
-index 0000000..db26834
---- /dev/null
-+++ b/spec/encode_spec.lua
-@@ -0,0 +1,11 @@
-+describe("encoding", function()
-+ setup(function()
-+ TOML = require "toml"
-+ end)
-+
-+ it("array", function()
-+ local obj = TOML.encode{ a = { "foo","bar" } }
-+ local sol = "a = [\nfoo,\nbar,\n]"
-+ assert.same(sol, obj)
-+ end)
-+end)
-
-From b914f26b66856d82d11d4c9205d5ccd97ae54bb6 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 14 Jun 2017 11:44:20 +0200
-Subject: [PATCH 2/2] fix encoding of plain ol borring arrays (issue #12)
-
----
- toml.lua | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/toml.lua b/toml.lua
-index a5655ed..b5eb2ed 100644
---- a/toml.lua
-+++ b/toml.lua
-@@ -619,7 +619,7 @@ TOML.encode = function(tbl)
- else
- -- plain ol boring array
- toml = toml .. k .. " = [\n"
-- for kk, vv in pairs(v) do
-+ for kk, vv in pairs(first) do
- toml = toml .. tostring(vv) .. ",\n"
- end
- toml = toml .. "]\n"