aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-polkit
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:09 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commit4dd718bf53cdde5b7cd6fad035e2020eb42a20c3 (patch)
tree6d7f72114c04725086be0849b1702777558b27c1 /community/mate-polkit
parent16fc94df27feef2e9064ff5a28ae6902c4cb7023 (diff)
downloadaports-4dd718bf53cdde5b7cd6fad035e2020eb42a20c3.tar.bz2
aports-4dd718bf53cdde5b7cd6fad035e2020eb42a20c3.tar.xz
main/mate-polkit: move to community
Diffstat (limited to 'community/mate-polkit')
-rw-r--r--community/mate-polkit/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/mate-polkit/APKBUILD b/community/mate-polkit/APKBUILD
new file mode 100644
index 0000000000..7f4cb35de0
--- /dev/null
+++ b/community/mate-polkit/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-polkit
+pkgver=1.10.2
+pkgrel=0
+pkgdesc="MATE Authentication Agent for PolicyKit"
+url="https://github.com/mate-desktop/mate-polkit"
+arch="all"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev polkit-dev libtool intltool gtk+2.0-dev
+ gobject-introspection-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="ebb243e915020380f11726c64daf31f7 mate-polkit-1.10.2.tar.xz"
+sha256sums="adc5576e1ee5deb8d586c15b34ef06cc04cfe502fd5d05eeacb889293247ef50 mate-polkit-1.10.2.tar.xz"
+sha512sums="159cc1baa1d4c58262c492e72509dea7eee18d338e81bf1bc3d7708b5097943ac463afb0c90fc939275fbf4818c67fe9b85cd0d993ef94e896783bcad1488188 mate-polkit-1.10.2.tar.xz"