aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-themes
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:10 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commit3fcf5e8dcddcc1a54da0a287a256e80842a96371 (patch)
tree782196b69176eafce3804c4995fc334294053289 /community/mate-themes
parent80b1e1022af532e0c13dc967b737ebba40adc78a (diff)
downloadaports-3fcf5e8dcddcc1a54da0a287a256e80842a96371.tar.bz2
aports-3fcf5e8dcddcc1a54da0a287a256e80842a96371.tar.xz
main/mate-themes: move to community
Diffstat (limited to 'community/mate-themes')
-rw-r--r--community/mate-themes/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/mate-themes/APKBUILD b/community/mate-themes/APKBUILD
new file mode 100644
index 0000000000..ce1afab6ca
--- /dev/null
+++ b/community/mate-themes/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-themes
+pkgver=1.9.0
+pkgrel=2
+pkgdesc="MATE themes"
+url="https://github.com/mate-desktop/mate-themes"
+arch="noarch"
+license="LGPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev intltool gdk-pixbuf-dev gtk+2.0-dev icon-naming-utils"
+install=""
+subpackages="$pkgname-lang"
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ --enable-all-themes \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="7e4c20e3bd82fa55b2695cb5bc9fb9df mate-themes-1.9.0.tar.xz"
+sha256sums="bda90434fc53d80fe15d44362c3851435b2e1a562ece243e489906340e31d36c mate-themes-1.9.0.tar.xz"
+sha512sums="e2ebe927cff9a6d6cd0fc6d37c510080fae2a7af64d70b59c0a892911c847d55e591a8f134d14059dcba406009f8b4c15e346fe28f64473a1b7c2415f385e69f mate-themes-1.9.0.tar.xz"