aboutsummaryrefslogtreecommitdiffstats
path: root/community/miniupnpc
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:56:58 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:56:58 +0200
commit0ea348258ece793cdfc28f8d57dceed8c29aef91 (patch)
treefaf38bf8697a965cdd80584847710c6477f06a72 /community/miniupnpc
parent3331da719022349c55f7a49f9aebbebe2f9a96b2 (diff)
downloadaports-0ea348258ece793cdfc28f8d57dceed8c29aef91.tar.bz2
aports-0ea348258ece793cdfc28f8d57dceed8c29aef91.tar.xz
testing/miniupnpc: move to community
Diffstat (limited to 'community/miniupnpc')
-rw-r--r--community/miniupnpc/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/miniupnpc/APKBUILD b/community/miniupnpc/APKBUILD
new file mode 100644
index 0000000000..ee44ab993c
--- /dev/null
+++ b/community/miniupnpc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=miniupnpc
+pkgver=2.0
+pkgrel=0
+pkgdesc="Library and tool to control NAT in UPnP-enabled routers"
+url="http://miniupnp.free.fr/"
+arch="all"
+license="BSD"
+makedepends="$depends_dev bsd-compat-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://miniupnp.free.fr/files/miniupnpc-$pkgver.tar.gz"
+
+builddir="$srcdir"/miniupnpc-$pkgver
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="$pkgdir" install || return 1
+}
+
+md5sums="2acc4ec912c15447a40cf14ae50df7b9 miniupnpc-2.0.tar.gz"
+sha256sums="d434ceb8986efbe199c5ca53f90ed53eab290b1e6d0530b717eb6fa49d61f93b miniupnpc-2.0.tar.gz"
+sha512sums="e8bca24265086518fa3bdc25fc31371ddf878adaa2bd6a80b30f33a3e5adb831220e906302832f2250e489a73ecd7e6c9a6bfcb1c70258a90e4c4712196275de miniupnpc-2.0.tar.gz"