aboutsummaryrefslogtreecommitdiffstats
path: root/community/mongodb
diff options
context:
space:
mode:
authorMarc Vertes <mvertes@free.fr>2017-11-12 16:53:10 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-11-14 07:17:43 +0000
commitb3a49a25c5fd50657a05053f16aa462a93c195b5 (patch)
tree4ef3bec42557f7655c4ead276254288f4c406c74 /community/mongodb
parenta5ff2c4e56dfe5eef87a0e342d39e124313e4e80 (diff)
downloadaports-b3a49a25c5fd50657a05053f16aa462a93c195b5.tar.bz2
aports-b3a49a25c5fd50657a05053f16aa462a93c195b5.tar.xz
community/mongodb: upgrade to 3.4.10
Diffstat (limited to 'community/mongodb')
-rw-r--r--community/mongodb/APKBUILD8
-rw-r--r--community/mongodb/fix-std-string.patch10
2 files changed, 4 insertions, 14 deletions
diff --git a/community/mongodb/APKBUILD b/community/mongodb/APKBUILD
index 478b8000b0..630d2ca01d 100644
--- a/community/mongodb/APKBUILD
+++ b/community/mongodb/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Filipp Andronov <filipp.andronov@gmail.com>
# Contributor: Marc Vertes <marc.vertes@ugrid.net>
pkgname=mongodb
-pkgver=3.4.9
-pkgrel=1
+pkgver=3.4.10
+pkgrel=0
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
arch='x86_64'
@@ -102,14 +102,14 @@ package() {
install -Dm644 "$srcdir/mongos.confd" "$pkgdir/etc/conf.d/mongos"
}
-sha512sums="b6803c91e9cda8e6963359386d2014d03f68151f64d580d5baacc3c66b2adabc62ee5c2cf203b9aee7d11942934afc6f9e17364d2f3aafd238ba88d13c77f26d mongodb-src-r3.4.9.tar.gz
+sha512sums="6293dde40a8433477ba3b1cf77abbdb32b28ce58279cc616b488647c8ab71b5ab3eab2146058c4a74b9e00f0938f1415020e2f26ea01f2b29dd78a1a38d58c3a mongodb-src-r3.4.10.tar.gz
56db8f43afc94713ac65b174189e2dd903b5e1eff0b65f1bdac159e52ad4de6606c449865d73bd47bffad6a8fc339777e2b11395596e9a476867d94a219c7925 40-fix-elf-native-class.patch
7d097f497cb910c9cb81086cd8c222e43456d1a6de4adfe3e97a4d99add454279350fdeb7305dab84b3deca04afd824036d4065ee0fb8cdd8c03e96d98ee86af backtrace.patch
f829b1ad542db3ee776d444243b8b47ab4e48a7386d9b199d7b1adafd31556cf173a5683b78ee735d6a69999ad9af5ad152fde955bbe8865f7910718991ce97c fix-asio-strerror_r.patch
8f2832f10e47b1a9f413ab44eb2b75dbb7bc47282d3ba721f35d4a93bc4fcf18b88c5f1c2f0ccf28539bbf81ee4c5715c5b71506fa680d22cde0630f9b3e2d22 fix-libressl.patch
9e109a9131e8466496e94f7046e13fd40ec750c8de703e31d65cf3f6e80830e67e1438debaefc0e1150fe2bb08dbb42cf95890c51e9d98f354cfbb396500b5d4 fix-log.patch
026d20fa1a0f1e27150b833664300250386d7e0d73c0778f81f70242e93e8a16e5607716693bbcdd1efb328fa84c7284e2c6c7e1ac92259b97a9d402975cf709 fix-processinfo_linux.patch
-de2523a2c0e3b2d56158ff697e69e3e5e1d65cb29e8a0f07a3a2794f6c4ba8abfe62d1871eb72c823f17399327f4741975a6424f011c95031e60e309d267ccd0 fix-std-string.patch
+a6c237f03fd09d960058eb92eab41e8dd7298e628a60656732d6751af90712d7359613b2c7241f7d893e675235631a9eef14495fbff8a52d25e792d62c3f6d30 fix-std-string.patch
1492137b0e3456d90a79617c1cd5ead5c71b1cfaae9ee41c75d56cd25f404ec73a690f95ce0d8c064c0a14206daca8070aa769b7cdfa904a338a425b52c293fa set-default-stacksize.patch
bbb323d428d59584703e8692bf4df7fe0d37c0324c23822bade2edd1ca78759191f778230b7107502a9d2f7f22afc84d4ea350139fc1d751ceb2fff219b9ddf8 wiredtiger-strtouq.patch
385c82875174caae433a3b381eb10f98a6fed0c8943788ddefff1de80a898e480bdbbf094a7783285cf2ae11ce3fc6878e57d58183d05be2f0837b206aaa4da6 boost160.patch
diff --git a/community/mongodb/fix-std-string.patch b/community/mongodb/fix-std-string.patch
index f2807a83f8..cf1953070e 100644
--- a/community/mongodb/fix-std-string.patch
+++ b/community/mongodb/fix-std-string.patch
@@ -29,16 +29,6 @@
Status LeafMatchExpression::setPath(StringData path) {
_path = path;
return _elementPath.init(_path);
---- mongodb-src-r3.4.7/src/mongo/util/net/miniwebserver.cpp.orig
-+++ mongodb-src-r3.4.7/src/mongo/util/net/miniwebserver.cpp
-@@ -45,6 +45,7 @@
- namespace mongo {
-
- using std::shared_ptr;
-+using std::string;
- using std::stringstream;
- using std::vector;
-
--- mongodb-src-r3.4.7/src/mongo/shell/bench.cpp.orig
+++ mongodb-src-r3.4.7/src/mongo/shell/bench.cpp
@@ -78,6 +78,7 @@