aboutsummaryrefslogtreecommitdiffstats
path: root/community/mongodb
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-16 06:32:17 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-16 06:45:42 +0000
commitfec51d2769e184e13be695f53829dbf055091f2c (patch)
treee3f53ee3f16183cfa6d3f3913fbaf9b39b9ce22f /community/mongodb
parent63aebc56fc52353039a6992bcf3dcef5dd2c6883 (diff)
downloadaports-fec51d2769e184e13be695f53829dbf055091f2c.tar.bz2
aports-fec51d2769e184e13be695f53829dbf055091f2c.tar.xz
community/mongodb: upgrade to 3.6.4
- rebuild against new libressl - remove libressl checks as of https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.0-relnotes.txt this should be converted to a version check and send upstream - disable tests because of 35GB+ disk usage - it seems that tests fail because of missing headers due to test build is build without local libs.
Diffstat (limited to 'community/mongodb')
-rw-r--r--community/mongodb/APKBUILD46
-rw-r--r--community/mongodb/libressl.patch22
2 files changed, 47 insertions, 21 deletions
diff --git a/community/mongodb/APKBUILD b/community/mongodb/APKBUILD
index 15eb21b78a..c93c16a162 100644
--- a/community/mongodb/APKBUILD
+++ b/community/mongodb/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Filipp Andronov <filipp.andronov@gmail.com>
# Contributor: Marc Vertes <mvertes@free.fr>
pkgname=mongodb
-pkgver=3.6.3
-pkgrel=2
+pkgver=3.6.4
+pkgrel=0
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
arch='x86_64'
+options="!check" # out of disk space (>35GB)
license='AGPL3'
pkgusers="mongodb"
pkggroups="mongodb"
@@ -21,27 +22,28 @@ source="http://downloads.mongodb.org/src/mongodb-src-r${pkgver}.tar.gz
fix-processinfo_linux.patch
fix-resolv.patch
fix-strerror_r.patch
+ libressl.patch
- mongodb.confd
- mongodb.initd
- mongodb.logrotate
- mongos.confd
- mongos.initd
+ mongodb.confd
+ mongodb.initd
+ mongodb.logrotate
+ mongos.confd
+ mongos.initd
"
builddir="$srcdir"/$pkgname-src-r$pkgver
_buildopts="
- --allocator=system \
- --disable-warnings-as-errors \
- --use-system-boost \
- --use-system-pcre \
- --use-system-stemmer \
- --use-system-wiredtiger \
- --use-system-snappy \
- --use-system-zlib \
- --use-system-yaml \
- --use-sasl-client \
- --ssl \
+ --allocator=system \
+ --disable-warnings-as-errors \
+ --use-system-boost \
+ --use-system-pcre \
+ --use-system-stemmer \
+ --use-system-wiredtiger \
+ --use-system-snappy \
+ --use-system-zlib \
+ --use-system-yaml \
+ --use-sasl-client \
+ --ssl \
"
build() {
@@ -54,12 +56,13 @@ build() {
check() {
cd "$builddir"
- scons unittests
+ export SCONSFLAGS="$MAKEFLAGS"
+ scons $_buildopts unittests
python buildscripts/resmoke.py --suites=unittests --jobs=2
}
package() {
- cd "$builddir"
+ cd "$builddir"
# install mongo targets
export SCONSFLAGS="$MAKEFLAGS"
@@ -81,13 +84,14 @@ package() {
install -Dm644 "$srcdir/mongos.confd" "$pkgdir/etc/conf.d/mongos"
}
-sha512sums="94aa9955f99d5f6bbbe65dc3755583952525398308ca7cb9224b91d1fa403de5bb3abb63a651583815cbecaff58966b5cfe7334a36ef6583f73d8c213410ddbc mongodb-src-r3.6.3.tar.gz
+sha512sums="02c2a697af9fdcbb16d19792be17d987e18c684418a63ed4750471c7ec22eb2eabf84e93cb1d298f67898b7e23687f668bb333c50ffc4e1b8adf8859f856ad95 mongodb-src-r3.6.4.tar.gz
05c4331d028eb396e6cf52d96cdaa2af7199a03522e1a8211df2d36cb053ec093a51e9abf83c4dc00c09a0b1fa119a79bcc719fbc81a48f50ca1527c26613cf0 fix-backtrace.patch
1492137b0e3456d90a79617c1cd5ead5c71b1cfaae9ee41c75d56cd25f404ec73a690f95ce0d8c064c0a14206daca8070aa769b7cdfa904a338a425b52c293fa fix-default-stacksize.patch
56db8f43afc94713ac65b174189e2dd903b5e1eff0b65f1bdac159e52ad4de6606c449865d73bd47bffad6a8fc339777e2b11395596e9a476867d94a219c7925 fix-elf-native-class.patch
026d20fa1a0f1e27150b833664300250386d7e0d73c0778f81f70242e93e8a16e5607716693bbcdd1efb328fa84c7284e2c6c7e1ac92259b97a9d402975cf709 fix-processinfo_linux.patch
aac12cffc452f1dc365c65944a015476c2011b0975144879d28938c690fe6e77b6bd672e040b4c04c02cb002224e24d6f13adb083324f424ef4cdb79a3a71f6b fix-resolv.patch
94078abfa74583afef6b5c1f0b334b257cfe87b0db7c13309a9c63d915913d5237c776dbb52f6a23e9409ec390d29e2f7225e9b8c8c5efcbc35b015c613f600c fix-strerror_r.patch
+45721f490f55f015ebdef497530048a36e78d64692be4a06c7f76963b60877e920350b6845385c33a7f6c6d428f60a1c73b083626d4f9567fa19f57ea32f6a3c libressl.patch
9bcd870742c31bf25f34188ddc3c414de1103e9860dea9f54eee276b89bc2cf1226abab1749c5cda6a6fb0880e541373754e5e83d63cc7189d4b9c274fd555c3 mongodb.confd
74009794d566dd9d70ec93ffd95c830ee4696165574ecf87398165637fb40799b38d182ef54c50fd0772d589be94ade7f7a49247f3d31c1f012cb4e44cc9f5df mongodb.initd
8c089b1a11f494e4148fb4646265964c925bf937633a65e395ee1361d42facf837871dd493a9a2e0f480ae0e0829dbd3ed60794c5334e2716332e131fc5c2c51 mongodb.logrotate
diff --git a/community/mongodb/libressl.patch b/community/mongodb/libressl.patch
new file mode 100644
index 0000000000..e6cecebb45
--- /dev/null
+++ b/community/mongodb/libressl.patch
@@ -0,0 +1,22 @@
+--- ./src/mongo/crypto/sha_block_openssl.cpp.orig
++++ ./src/mongo/crypto/sha_block_openssl.cpp
+@@ -44,7 +44,7 @@
+ #include <openssl/hmac.h>
+ #include <openssl/sha.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ namespace {
+ // Copies of OpenSSL after 1.1.0 define new EVP digest routines. We must
+ // polyfill used definitions to interact with older OpenSSL versions.
+--- ./src/mongo/util/net/ssl_manager.cpp.orig
++++ ./src/mongo/util/net/ssl_manager.cpp
+@@ -237,7 +237,7 @@
+ #endif // MONGO_CONFIG_NEEDS_ASN1_ANY_DEFINITIONS
+ // clang-format on
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ // Copies of OpenSSL after 1.1.0 define new functions for interaction with
+ // X509 structure. We must polyfill used definitions to interact with older
+ // OpenSSL versions.