aboutsummaryrefslogtreecommitdiffstats
path: root/community/msttcorefonts-installer
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-14 09:01:49 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-14 09:02:19 +0000
commitcc5299d631bdee95afdb7dd6b4ce52b232e154d3 (patch)
tree40661c153add39f67bd90208eb0ca09acc347fe2 /community/msttcorefonts-installer
parent92887a9601007413e45f0076631259dd541eba58 (diff)
downloadaports-cc5299d631bdee95afdb7dd6b4ce52b232e154d3.tar.bz2
aports-cc5299d631bdee95afdb7dd6b4ce52b232e154d3.tar.xz
community/msttcorefonts-installer: move into community
Diffstat (limited to 'community/msttcorefonts-installer')
-rw-r--r--community/msttcorefonts-installer/APKBUILD42
-rwxr-xr-xcommunity/msttcorefonts-installer/msttcorefonts-installer.post-install5
-rw-r--r--community/msttcorefonts-installer/remove-debian-stuff.patch33
3 files changed, 80 insertions, 0 deletions
diff --git a/community/msttcorefonts-installer/APKBUILD b/community/msttcorefonts-installer/APKBUILD
new file mode 100644
index 0000000000..b2894c594c
--- /dev/null
+++ b/community/msttcorefonts-installer/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=msttcorefonts-installer
+pkgver=3.6
+pkgrel=1
+pkgdesc="Installer for Microsoft TrueType core fonts"
+url="https://packages.debian.org/sid/ttf-mscorefonts-installer"
+arch="noarch"
+license="GPL"
+depends="cabextract wget"
+depends_dev=
+makedepends="$depends_dev"
+install="$pkgname.post-install"
+subpackages=
+source="http://http.debian.net/debian/pool/contrib/m/msttcorefonts/msttcorefonts_$pkgver.tar.gz
+ remove-debian-stuff.patch
+ "
+builddir="$srcdir"/msttcorefonts
+
+prepare() {
+ cd "$builddir"
+ default_prepare || return 1
+}
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p /usr/share/fonts/truetype/msttcorefonts
+ install -m755 -D update-ms-fonts "$pkgdir"/usr/bin/update-ms-fonts
+ install -m644 -D cabfiles.sha256sums \
+ "$pkgdir"/var/lib/msttcorefonts/cabfiles.sha256sums
+}
+
+md5sums="2ae4a78471ab4f6684847a02fa072c17 msttcorefonts_3.6.tar.gz
+73f1c14674f929d0c6ef11aedc1a8d43 remove-debian-stuff.patch"
+sha256sums="c23a2c519acad44fb65dfdd5b6f7de7b351ec15394df52cc744e3c6deb51d42f msttcorefonts_3.6.tar.gz
+da6528a10b35f6c14b0d0a433b10aef7552833ec25c1bc399c3917c81841b97d remove-debian-stuff.patch"
+sha512sums="1b91d07f10dd554376f8261213a15644f9d6f5e45bec4c1d3160530882ced73a093232c0cf30a024fce706c30df97afc867c7c70d7afe9d62bd71a081fee52d4 msttcorefonts_3.6.tar.gz
+7a5fa404adcecd9a314ab448007a1c50fd4392d7712139fbc702e6e0f43160366b1c6da90d743c2b57dd1566d7e6ae9c6fc4c56106c4c6b5b29d6370df0c3361 remove-debian-stuff.patch"
diff --git a/community/msttcorefonts-installer/msttcorefonts-installer.post-install b/community/msttcorefonts-installer/msttcorefonts-installer.post-install
new file mode 100755
index 0000000000..36c7e0d0a0
--- /dev/null
+++ b/community/msttcorefonts-installer/msttcorefonts-installer.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+echo "*" >&2
+echo -e "* With root permissions run \"update-ms-fonts\" and once completed" >&2
+echo -e "* run \"fc-cache -f\" in order to update the font cache" >&2
+echo -e "*" >&2
diff --git a/community/msttcorefonts-installer/remove-debian-stuff.patch b/community/msttcorefonts-installer/remove-debian-stuff.patch
new file mode 100644
index 0000000000..52ea32bc25
--- /dev/null
+++ b/community/msttcorefonts-installer/remove-debian-stuff.patch
@@ -0,0 +1,33 @@
+--- a/update-ms-fonts
++++ b/update-ms-fonts
+@@ -34,7 +34,7 @@
+ mstt_exit_with_error() {
+ echo "$1"
+ echo "The fonts are NOT installed."
+- echo "Please run 'dpkg-reconfigure ttf-mscorefonts-installer' to perform the installation again"
++ echo "Please run 'update-ms-fonts' to perform the installation again"
+ exit 0 # still install the Debian package
+ }
+
+@@ -190,11 +190,6 @@
+ # Give sane names. These are nearly the same names MS uses for the
+ # Macintosh versions
+
+- mkdir -p /usr/share/doc/ttf-mscorefonts-installer $FONTDIR
+- if [ -e licen.txt ] ; then
+- mv licen.txt '/usr/share/doc/ttf-mscorefonts-installer/READ_ME!'
+- gzip -f -9 '/usr/share/doc/ttf-mscorefonts-installer/READ_ME!'
+- fi
+ for ff in $FONTFILES; do
+ for ttf in `grep $ff msfonts.info | awk '{print $4}'`; do
+ longname=`awk "/$ttf/ { print \\$2 }" msfonts.info`
+@@ -203,9 +198,6 @@
+ done
+ done
+
+- # Make a note of what we installed so we can uninstall it later
+- awk '{print $2}' msfonts.info > /var/lib/msttcorefonts/ms-fonts
+- awk '{print $4}' msfonts.info >> /var/lib/msttcorefonts/ms-fonts
+ fi
+
+ cd /