aboutsummaryrefslogtreecommitdiffstats
path: root/community/namecoin
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-09-04 23:35:18 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-09-08 21:57:25 +0200
commitee9edf5ad90396e4015f21fc897bcf32f3582d76 (patch)
tree5c9bc221e6d95e02cfa41c42da2e51bb46273164 /community/namecoin
parent9be33aa809af1a7bb2abfa32a27aec44c041dcdf (diff)
downloadaports-ee9edf5ad90396e4015f21fc897bcf32f3582d76.tar.bz2
aports-ee9edf5ad90396e4015f21fc897bcf32f3582d76.tar.xz
community/namecoin: update to 0.13.0-rc1
https://github.com/namecoin/namecoin-core/blob/master/Changes
Diffstat (limited to 'community/namecoin')
-rw-r--r--community/namecoin/12-fix-miniupnpc.patch17
-rw-r--r--community/namecoin/20-boost-multithread-dynamic.patch33
-rw-r--r--community/namecoin/31-set-default-env-function.patch61
-rw-r--r--community/namecoin/APKBUILD125
-rw-r--r--community/namecoin/namecoin.initd4
-rw-r--r--community/namecoin/ssize_t.patch12
-rw-r--r--community/namecoin/system-strlcpy.patch60
7 files changed, 88 insertions, 224 deletions
diff --git a/community/namecoin/12-fix-miniupnpc.patch b/community/namecoin/12-fix-miniupnpc.patch
deleted file mode 100644
index bf226df8a4..0000000000
--- a/community/namecoin/12-fix-miniupnpc.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- namecoin-nc*/src/net.cpp
-+++ namecoin-nc*/src/net.cpp
-@@ -19,10 +19,10 @@
- #endif
-
- #ifdef USE_UPNP
--#include <miniwget.h>
--#include <miniupnpc.h>
--#include <upnpcommands.h>
--#include <upnperrors.h>
-+#include <miniupnpc/miniwget.h>
-+#include <miniupnpc/miniupnpc.h>
-+#include <miniupnpc/upnpcommands.h>
-+#include <miniupnpc/upnperrors.h>
- #endif
-
- using namespace std;
diff --git a/community/namecoin/20-boost-multithread-dynamic.patch b/community/namecoin/20-boost-multithread-dynamic.patch
deleted file mode 100644
index 4adf46f349..0000000000
--- a/community/namecoin/20-boost-multithread-dynamic.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- namecoin-nc*/src/Makefile
-+++ namecoin-nc*/src/Makefile
-@@ -9,24 +9,20 @@
- DEFS += -DBOOST_THREAD_USE_LIB
-
- INCLUDEPATHS= \
-- -I../libs/openssl-1.0.1i/include \
-- -I../libs/db-4.7.25.NC/build_unix \
-- -I../libs/boost_1_50_0
-+ -I/usr/include
-
- LIBPATHS= \
-- -L../libs/openssl-1.0.1i \
-- -L../libs/db-4.7.25.NC/build_unix \
-- -L../libs/boost_1_50_0/stage/lib
-+ -L/usr/lib
-
- LIBBOOST_SUFFIX=
-
- LIBS= \
-- -Wl,-Bstatic \
-+ -Wl,-Bdynamic \
- -l boost_system$(LIBBOOST_SUFFIX) \
- -l boost_filesystem$(LIBBOOST_SUFFIX) \
-- -l boost_program_options$(LIBBOOST_SUFFIX) \
-- -l boost_thread$(LIBBOOST_SUFFIX) \
-- -l boost_chrono$(LIBBOOST_SUFFIX) \
-+ -l boost_program_options-mt$(LIBBOOST_SUFFIX) \
-+ -l boost_thread-mt$(LIBBOOST_SUFFIX) \
-+ -l boost_chrono-mt$(LIBBOOST_SUFFIX) \
- -l db_cxx \
- -l ssl \
- -l crypto
diff --git a/community/namecoin/31-set-default-env-function.patch b/community/namecoin/31-set-default-env-function.patch
deleted file mode 100644
index 9af0446cfd..0000000000
--- a/community/namecoin/31-set-default-env-function.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- namecoin-nc*/src/init.cpp
-+++ namecoin-nc*/src/init.cpp
-@@ -99,6 +99,10 @@
- #ifndef GUI
- int main(int argc, char* argv[])
- {
-+ #ifndef WIN32
-+ SetupEnvironment();
-+ #endif
-+
- bool fRet = false;
- fRet = AppInit(argc, argv);
-
---- namecoin-nc*/src/qt/bitcoin.cpp
-+++ namecoin-nc*/src/qt/bitcoin.cpp
-@@ -124,6 +124,10 @@
- #ifndef BITCOIN_QT_TEST
- int main(int argc, char *argv[])
- {
-+ #ifndef WIN32
-+ SetupEnvironment();
-+ #endif
-+
- // Command-line options take precedence:
- ParseParameters(argc, argv);
-
---- namecoin-nc*/src/util.cpp
-+++ namecoin-nc*/src/util.cpp
-@@ -1114,3 +1114,20 @@
- }
- return true;
- }
-+
-+#ifndef WIN32
-+void SetupEnvironment()
-+{
-+ try
-+ {
-+ #if BOOST_FILESYSTEM_VERSION == 3
-+ boost::filesystem::path::codecvt(); // Raises runtime error if current locale is invalid
-+ #else // boost filesystem v2
-+ std::locale(); // Raises runtime error if current locale is invalid
-+ #endif
-+ } catch(std::runtime_error &e)
-+ {
-+ setenv("LC_ALL", "C", 1); // Force C locale
-+ }
-+}
-+#endif
-
---- namecoin-nc0.3.76/src/util.h
-+++ namecoin-nc0.3.76/src.new/util.h
-@@ -211,6 +211,7 @@
-
- void RandAddSeed();
- void RandAddSeedPerfmon();
-+void SetupEnvironment();
- int OutputDebugStringF(const char* pszFormat, ...);
- int my_snprintf(char* buffer, size_t limit, const char* format, ...);
-
-
diff --git a/community/namecoin/APKBUILD b/community/namecoin/APKBUILD
index a2d5eff343..26504d3f20 100644
--- a/community/namecoin/APKBUILD
+++ b/community/namecoin/APKBUILD
@@ -1,75 +1,98 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=namecoin
-pkgver=0.3.80
-pkgrel=1
+pkgver=0.13.0_rc1
+_ver=${pkgver/_/}
+pkgrel=0
pkgdesc="Namecoin is a peer to peer DNS based on bitcoin"
-url="https://github.com/namecoin/namecoin"
-arch=""
-license="GPL"
-depends=""
-depends_dev="openssl-dev db-dev boost-dev miniupnpc-dev glib-dev qt5-qtbase-dev qt5-qttools-dev"
-makedepends="$depends_dev bsd-compat-headers"
+url="http://www.namecoin.org/"
+arch="all"
+license="MIT"
+makedepends="$depends_dev autoconf automake libtool boost-dev openssl-dev
+ db-dev miniupnpc-dev qt5-qtbase-dev qt5-qttools-dev protobuf-dev
+ libqrencode-dev libevent-dev chrpath"
install="$pkgname.post-install $pkgname.pre-install"
-subpackages="$pkgname-qt"
-source="$pkgname-$pkgver.tar.gz::https://github.com/namecoin/namecoin/archive/nc$pkgver.tar.gz
- 20-boost-multithread-dynamic.patch
- system-strlcpy.patch
+subpackages="$pkgname-dev $pkgname-qt $pkgname-cli $pkgname-tx $pkgname-tests $pkgname-bench"
+source="$pkgname-$_ver.tar.gz::https://github.com/$pkgname/$pkgname-core/archive/nc${_ver}.tar.gz
+ ssize_t.patch
$pkgname.initd
$pkgname.conf
"
-
-_builddir="$srcdir"/namecoin-nc$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-core-nc$_ver"
build() {
- cd "$_builddir"/src
- # build namecoind
- make USE_UPNP=1 USE_SSL=1 || return 1
- cd ..
- # build namecoin-qt
- qmake
- # Fix boost_multi thread linking in the GUI too
- sed -i 's/-lboost_thread/-lboost_thread-mt/g' ./Makefile
- sed -i 's/-lboost_program_options/-lboost_program_options-mt/g' ./Makefile
- sed -i 's/-lboost_chrono/-lboost_chrono-mt/g' ./Makefile
+ cd "$builddir"
+ ./autogen.sh
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-incompatible-bdb \
+ --with-gui=qt5 \
+ --with-utils \
+ --disable-ccache \
+ --disable-static \
+ --enable-hardening \
+ || return 1
make || return 1
}
package() {
- cd "$_builddir"/src
- install -Dm755 namecoind "$pkgdir"/usr/bin/namecoind || return 1
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" || return 1
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
install -m600 -D "$srcdir"/$pkgname.conf "$pkgdir"/etc/$pkgname.conf || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
}
qt() {
- pkgdesc="Namecoin with a Qt frontend"
- cd "$_builddir"
- mkdir -p "$subpkgdir"/usr/bin
- install -Dm755 namecoin-qt "$subpkgdir"/usr/bin/namecoin-qt || return 1
+ pkgdesc="Namecoin with a Qt frontend & QR Code support"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/$pkgname-qt "$subpkgdir"/usr/bin/ || return 1
+}
+
+cli() {
+ pkgdesc="Namecoin CLI"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/$pkgname-cli "$subpkgdir"/usr/bin/ || return 1
+}
+
+tx() {
+ pkgdesc="Namecoin TX (Transaction Tool)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/$pkgname-tx "$subpkgdir"/usr/bin/ || return 1
+}
+
+tests() {
+ pkgdesc="Namecoin & Namecoin-QT Unit Tests)"
+ mkdir -p "$subpkgdir"/usr/bin
+ chrpath -d "$pkgdir"/usr/bin/test_namecoin || return 1
+ mv "$pkgdir"/usr/bin/test_$pkgname-qt "$subpkgdir"/usr/bin/ || return 1
+ mv "$pkgdir"/usr/bin/test_$pkgname "$subpkgdir"/usr/bin/ || return 1
+}
+
+bench() {
+ pkgdesc="Namecoin Benchmarking Tools"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/bench_$pkgname "$subpkgdir"/usr/bin/ || return 1
+}
+
+dev() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr/ || return 1
+ mv "$pkgdir"/usr/include "$subpkgdir"/usr/ || return 1
}
-md5sums="7302f83d8390184139277255a6c1d484 namecoin-0.3.80.tar.gz
-e4e43d7420191a94500189fe58a34a9c 20-boost-multithread-dynamic.patch
-3350b82aec4eb1edb2555c0b0e8b0451 system-strlcpy.patch
-9ecdbd9e17240075d064498a80fd50bd namecoin.initd
+md5sums="f18f88080d92cf3aa35b21496e4f9139 namecoin-0.13.0rc1.tar.gz
+716a88e668729e89d3eb929da86f7f04 ssize_t.patch
+826110b59ab23776065a7666599409a3 namecoin.initd
59b2e0e765738ba48f632051fb6917ae namecoin.conf"
-sha256sums="3f5e5af95cea46111d3cf1663f0e84d5fda653917745e0607a3ca4773baea59c namecoin-0.3.80.tar.gz
-1b0e2c1c3ca849df816405c9f8dd86e056daed213c3e4c4e72161cabd64e67e8 20-boost-multithread-dynamic.patch
-44ff4beb1a10bd1e6a0f984a37d69e025b2c2b5de58af300ec5c23fd3e83f67e system-strlcpy.patch
-04ae66115343aa8ed7343139a2370b1e570c8ab4397d09457f5f157dd906a204 namecoin.initd
+sha256sums="1f52c1809680effe32d4b94c33136cc051364248578033fbcdca06ed630784ad namecoin-0.13.0rc1.tar.gz
+f0a094c7b374338ad153ee06b7dd2369dad6b97b1f1bb0252da12c9aaace5321 ssize_t.patch
+18a64147ae9212211b036b3d873ad43a88897fba5e3e3328c52ad66407c89fee namecoin.initd
4b413833527929ea863351469a5a4fc1e0ac365fe9df5e8a8304d8667acf8cea namecoin.conf"
-sha512sums="6ff3fddd72cf8ed4224b42deb6a7ca50906262cb50c3ca5ccb419791daa474d52b9584cbc47240fa7546c3f23fe23b72af475f16d1dd110ab13098e3e60a5de6 namecoin-0.3.80.tar.gz
-fc13574fef73cca20178e5895e2327567f40c91d25105d72b301a155f9025bfb494ce337096424fd71da8034fb0544562b8459c1d8ae2598ee503efd5995c6bf 20-boost-multithread-dynamic.patch
-8701c8faf786420a7085a8e5d85080fe18f26e53ae346c1c897315fd7f8f00e1f1e326ed5917b0eefa8f74bc7470e8979c1b10515017584baa2e9feb3c39b205 system-strlcpy.patch
-3048248b3da7300b0b3cb5667283badc17b41e6c90573604fd9ea9eb9933e93f9b1d6288846793b4e7a001a4cae5e52d2ce42e4bdc83e48f72aca6ee0e8ddd43 namecoin.initd
+sha512sums="c495e1ef4fa45219c1bec49c0f0d81661a55b2eabb8fce291c1316086589438cd9ae129dc4ce63cb845646cf28f2b4fd46c0d87ed315167c82dbdf447a4eb38b namecoin-0.13.0rc1.tar.gz
+98aa5ad81bdb4ae961b791bc978c39117cdf2d83c2181f92bebbb0db107d9b6e86eda265fb3f93ff8a5ca8a7754d7148818b98095d57201dff9363d60b97e7dd ssize_t.patch
+1753132f349e02cc248a622eb17f2f98a180d561d46f2e8916b84cc26c98d546214ca305bb1ea378ae14090c0abf8d6ac257c98c6776bbe4dabd68c108f595a3 namecoin.initd
3f92cb9a5f66d0e9e3792691b2e62b929c092030273bb87ebd9564e0c02196a5a9f69c458162f1b35099ac28e9b79b1c4035144b9d2dae4ad3e87d05a40d7ed4 namecoin.conf"
diff --git a/community/namecoin/namecoin.initd b/community/namecoin/namecoin.initd
index 9bdeea0893..a347a84f76 100644
--- a/community/namecoin/namecoin.initd
+++ b/community/namecoin/namecoin.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
# Namecoin init.d file for Alpine Linux.
@@ -9,7 +9,7 @@ user=namecoin
group=namecoin
## supercedes datadir set in $config ##
datadir=/var/lib/namecoin
-pidfile=/var/run/namecoin/$name.pid
+pidfile=/run/namecoin/$name.pid
depend() {
need net
diff --git a/community/namecoin/ssize_t.patch b/community/namecoin/ssize_t.patch
new file mode 100644
index 0000000000..2c21854ea3
--- /dev/null
+++ b/community/namecoin/ssize_t.patch
@@ -0,0 +1,12 @@
+diff --git a/src/leveldb/db/db_iter.cc b/src/leveldb/db/db_iter.cc
+index 071a54e..68a18f2 100644
+--- a/src/leveldb/db/db_iter.cc
++++ b/src/leveldb/db/db_iter.cc
+@@ -2,6 +2,7 @@
+ // Use of this source code is governed by a BSD-style license that can be
+ // found in the LICENSE file. See the AUTHORS file for names of contributors.
+
++#include <sys/types.h>
+ #include "db/db_iter.h"
+
+ #include "db/filename.h"
diff --git a/community/namecoin/system-strlcpy.patch b/community/namecoin/system-strlcpy.patch
deleted file mode 100644
index f7bb2717df..0000000000
--- a/community/namecoin/system-strlcpy.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff --git a/src/init.cpp b/src/init.cpp
-index bc7e714..295e20f 100644
---- a/src/init.cpp
-+++ b/src/init.cpp
-@@ -6,7 +6,6 @@
- #include "bitcoinrpc.h"
- #include "net.h"
- #include "init.h"
--#include "strlcpy.h"
- #include <boost/filesystem.hpp>
- #include <boost/filesystem/fstream.hpp>
- #include <boost/interprocess/sync/file_lock.hpp>
-diff --git a/src/irc.cpp b/src/irc.cpp
-index fea0aa2..fd5d8c4 100644
---- a/src/irc.cpp
-+++ b/src/irc.cpp
-@@ -5,7 +5,6 @@
- #include "headers.h"
- #include "irc.h"
- #include "net.h"
--#include "strlcpy.h"
-
- using namespace std;
- using namespace boost;
-diff --git a/src/net.cpp b/src/net.cpp
-index 4d2f651..7df2b77 100644
---- a/src/net.cpp
-+++ b/src/net.cpp
-@@ -7,7 +7,6 @@
- #include "db.h"
- #include "net.h"
- #include "init.h"
--#include "strlcpy.h"
-
- #ifdef __WXMSW__
- #include <string.h>
-diff --git a/src/qt/bitcoin.cpp b/src/qt/bitcoin.cpp
-index 30dcca6..21a11af 100644
---- a/src/qt/bitcoin.cpp
-+++ b/src/qt/bitcoin.cpp
-@@ -15,7 +15,6 @@
- #include "ui_interface.h"
- #include "paymentserver.h"
- #include "../allocators.h"
--#include "../strlcpy.h"
-
- #include <boost/filesystem.hpp>
-
-diff --git a/src/util.cpp b/src/util.cpp
-index fc51717..50ce19f 100644
---- a/src/util.cpp
-+++ b/src/util.cpp
-@@ -2,7 +2,6 @@
- // Distributed under the MIT/X11 software license, see the accompanying
- // file license.txt or http://www.opensource.org/licenses/mit-license.php.
- #include "headers.h"
--#include "strlcpy.h"
- #include <boost/program_options/detail/config_file.hpp>
- #include <boost/program_options/parsers.hpp>
- #include <boost/filesystem.hpp>