aboutsummaryrefslogtreecommitdiffstats
path: root/community/ncmpc
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-04-14 13:45:02 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-04-14 14:00:46 +0200
commite3b2306d4645de4d1aeb54b9a450c11d1c46068b (patch)
tree2ef8d15570a1167c5a5c0c25037bd248276ad6b5 /community/ncmpc
parente51d7330b6ddb2c0c255a72dd3bb6e45713c978f (diff)
downloadaports-e3b2306d4645de4d1aeb54b9a450c11d1c46068b.tar.bz2
aports-e3b2306d4645de4d1aeb54b9a450c11d1c46068b.tar.xz
community/ncmpc: include upstream fix for progress bar without colors
Diffstat (limited to 'community/ncmpc')
-rw-r--r--community/ncmpc/0001-Fix-blank-progressbar-when-colors-are-not-in-use.patch39
-rw-r--r--community/ncmpc/APKBUILD8
2 files changed, 44 insertions, 3 deletions
diff --git a/community/ncmpc/0001-Fix-blank-progressbar-when-colors-are-not-in-use.patch b/community/ncmpc/0001-Fix-blank-progressbar-when-colors-are-not-in-use.patch
new file mode 100644
index 0000000000..f3b36fdd02
--- /dev/null
+++ b/community/ncmpc/0001-Fix-blank-progressbar-when-colors-are-not-in-use.patch
@@ -0,0 +1,39 @@
+From fa73e3faa29af8638d2557c6c808bda9dc67afc2 Mon Sep 17 00:00:00 2001
+From: Aleksi Blinnikka <aleksi.blinnikka@gmail.com>
+Date: Tue, 10 Apr 2018 02:33:30 +0300
+Subject: [PATCH] Fix blank progressbar when colors are not in use
+
+When moving wbkgd() call in 9c22a95 it was not conditional like it was
+for others (commits 7946611 and 6b337bc), which caused progress bar to
+not show.
+---
+ src/ProgressBar.cxx | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/ProgressBar.cxx b/src/ProgressBar.cxx
+index 7ddc72f..02782db 100644
+--- a/src/ProgressBar.cxx
++++ b/src/ProgressBar.cxx
+@@ -19,6 +19,7 @@
+
+ #include "ProgressBar.hxx"
+ #include "colors.hxx"
++#include "options.hxx"
+
+ #include <assert.h>
+
+@@ -26,7 +27,10 @@ ProgressBar::ProgressBar(Point p, unsigned _width)
+ :window(p, {_width, 1u})
+ {
+ leaveok(window.w, true);
+- wbkgd(window.w, COLOR_PAIR(COLOR_PROGRESSBAR));
++#ifdef ENABLE_COLORS
++ if (options.enable_colors)
++ wbkgd(window.w, COLOR_PAIR(COLOR_PROGRESSBAR));
++#endif
+ }
+
+ void
+--
+2.17.0
+
diff --git a/community/ncmpc/APKBUILD b/community/ncmpc/APKBUILD
index b594067ae1..1ada9256e1 100644
--- a/community/ncmpc/APKBUILD
+++ b/community/ncmpc/APKBUILD
@@ -3,14 +3,15 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=ncmpc
pkgver=0.30
-pkgrel=0
+pkgrel=1
pkgdesc="Ncurses client for the Music Player Daemon (MPD)"
url="https://www.musicpd.org/clients/ncmpc"
arch="all"
license="GPL-2.0-or-later"
makedepends="glib-dev libmpdclient-dev meson ncurses-dev"
subpackages="$pkgname-doc $pkgname-lang $pkgname-dbg"
-source="http://www.musicpd.org/download/$pkgname/0/$pkgname-$pkgver.tar.xz"
+source="http://www.musicpd.org/download/$pkgname/0/$pkgname-$pkgver.tar.xz
+ 0001-Fix-blank-progressbar-when-colors-are-not-in-use.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -42,4 +43,5 @@ package() {
"$pkgdir"/usr/share/$pkgname/lyrics
}
-sha512sums="bc92c51c78f7919eb6b5cebaac8bda1231701fd9011fcadd6da8bbc5cc16e5dbe30d33d6e2f7d4cc07399299bcd3de572c9516f90d0376212771fd2c3af8afc7 ncmpc-0.30.tar.xz"
+sha512sums="bc92c51c78f7919eb6b5cebaac8bda1231701fd9011fcadd6da8bbc5cc16e5dbe30d33d6e2f7d4cc07399299bcd3de572c9516f90d0376212771fd2c3af8afc7 ncmpc-0.30.tar.xz
+b153014180e2efc18f458a375ad3507f74bb98a5d7272fe1b1234a2d54ed2d70194115980ea8f33b4854647cbd16e49b4a2427100bf10b96b628a39d98154e3e 0001-Fix-blank-progressbar-when-colors-are-not-in-use.patch"