aboutsummaryrefslogtreecommitdiffstats
path: root/community/neko
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2018-02-09 15:49:31 +0800
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-23 11:25:22 +0000
commite5102fb8536ae7e3bd4fd39d4803fe923ac0c89f (patch)
tree64bb2bc3eaa6ca91afa3c00a436f12f9ad4d1bab /community/neko
parenta492a00259d03be66aee896c4e71e63f0622f2aa (diff)
downloadaports-e5102fb8536ae7e3bd4fd39d4803fe923ac0c89f.tar.bz2
aports-e5102fb8536ae7e3bd4fd39d4803fe923ac0c89f.tar.xz
testing/neko: move to community
Diffstat (limited to 'community/neko')
-rw-r--r--community/neko/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/neko/APKBUILD b/community/neko/APKBUILD
new file mode 100644
index 0000000000..cde0aea6be
--- /dev/null
+++ b/community/neko/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Maintainer: Andy Li <andy@onthewings.net>
+pkgname=neko
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="High-level dynamically typed programming language"
+url="https://nekovm.org/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="neko"
+makedepends="apache2-dev cmake gc-dev gtk+2.0-dev linux-headers mariadb-dev
+ mbedtls-dev ninja sqlite-dev"
+options=""
+install=""
+subpackages="$pkgname-dev $pkgname-libs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/HaxeFoundation/neko/archive/v${pkgver//./-}.tar.gz"
+
+builddir="$srcdir/$pkgname-${pkgver//./-}"
+build() {
+ cd "$builddir"
+
+ mkdir -p build || return 1
+ cd build || return 1
+
+ cmake "../" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DNEKO_JIT_DISABLE=ON -GNinja || return 1
+ ninja || return 1
+}
+
+check() {
+ cd "$builddir"
+ ninja -C build test || return 1
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C build install || return 1
+}
+sha512sums="4bc89fddf4a5ae94e73843b06a3b6fe8de59d72922764276a5bd9d56daf6570525e842039bf704598b41e1de4a5fe08931adc4ca9730fe3333be0beb7a1ccaed neko-2.2.0.tar.gz"