aboutsummaryrefslogtreecommitdiffstats
path: root/community/nethogs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-16 12:57:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-16 12:58:03 +0200
commit080bc4539da884ff321834b7d8b80465e53869b9 (patch)
treef2d3c672b698f8ea10bed6293a85ecde54313d45 /community/nethogs
parent13b727f6aa3225b88e620bfc9f44e190c3fccd36 (diff)
downloadaports-080bc4539da884ff321834b7d8b80465e53869b9.tar.bz2
aports-080bc4539da884ff321834b7d8b80465e53869b9.tar.xz
community/nethogs: move from testing
Diffstat (limited to 'community/nethogs')
-rw-r--r--community/nethogs/APKBUILD29
-rw-r--r--community/nethogs/set-version.patch8
2 files changed, 37 insertions, 0 deletions
diff --git a/community/nethogs/APKBUILD b/community/nethogs/APKBUILD
new file mode 100644
index 0000000000..500743424e
--- /dev/null
+++ b/community/nethogs/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Łukasz Jendrysik <scadu@yandex.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=nethogs
+pkgver=0.8.5
+pkgrel=0
+pkgdesc="Top-like monitor for network traffic"
+url="https://github.com/raboof/nethogs"
+arch="all"
+license="GPL"
+makedepends="libpcap-dev linux-headers ncurses-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/raboof/$pkgname/archive/v$pkgver.tar.gz
+ set-version.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ VERSION="$pkgver" make nethogs
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 src/nethogs "$pkgdir"/usr/sbin/nethogs
+ install -Dm644 doc/nethogs.8 "$pkgdir"/usr/share/man/man8/nethogs.8
+}
+
+sha512sums="a2be81fcebc9925dd8a0fd9f71c6e790206819e0cc5efeeeb0c741baa9fd25ec685a1784b6d331d938cf14381403f9c13d619509d0ffe713ce8786a83a380908 nethogs-0.8.5.tar.gz
+81d44aea5fa585d80a52f562b308046d6d173e277ab6fdc1e289eda65cfcfbd5bec379c70eb94052a86d8f2e008dc44be3894fca8d74c5b6754753e609422b3e set-version.patch"
diff --git a/community/nethogs/set-version.patch b/community/nethogs/set-version.patch
new file mode 100644
index 0000000000..35f6c43044
--- /dev/null
+++ b/community/nethogs/set-version.patch
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-export VERSION := $(shell ./determineVersion.sh)
++export VERSION ?= $(shell ./determineVersion.sh)
+
+ #export PREFIX := /usr
+ export PREFIX ?= /usr/local