aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud-client
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-03-27 11:41:06 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-03-27 11:41:06 +0000
commit66ccd415eea74624f66ef54a6982e3db73426cd6 (patch)
treed1c798ef451bc4b56b4f9257dfc611ec7c8c01a8 /community/nextcloud-client
parent5b6549c76202aeb796db4943d70982f683f464bd (diff)
downloadaports-66ccd415eea74624f66ef54a6982e3db73426cd6.tar.bz2
aports-66ccd415eea74624f66ef54a6982e3db73426cd6.tar.xz
community/nextcloud-client: moved from testing
Diffstat (limited to 'community/nextcloud-client')
-rw-r--r--community/nextcloud-client/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/nextcloud-client/APKBUILD b/community/nextcloud-client/APKBUILD
new file mode 100644
index 0000000000..4011bc709a
--- /dev/null
+++ b/community/nextcloud-client/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=nextcloud-client
+_realname=client_theming
+pkgver=2.3.1
+pkgrel=0
+pkgdesc="Nextcloud Desktop Client"
+url="https://github.com/nextcloud/client_theming"
+arch="all"
+license="GPL2"
+depends=
+depends_dev=
+makedepends="$depends_dev cmake qt5-qttools-dev qt5-qtwebkit-dev
+ qt5-qtkeychain-dev"
+install=
+subpackages="$pkgname-dev"
+source="owncloud-client-$pkgver.tar.gz::https://github.com/owncloud/client/archive/v$pkgver.tar.gz
+ $pkgname-$pkgver.tar.gz::https://github.com/nextcloud/$_realname/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir"/client-$pkgver
+
+build() {
+ cd "$builddir"
+ # mkdir _build.tmp && cd _build.tmp
+ cmake \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/$pkgname \
+ -DOEM_THEME_DIR="$srcdir/$_realname-$pkgver/nextcloudtheme"
+ make all || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="582a017431da41a0bf2ad745e24560b0641ac815c6c296b2a5bdfa4e56e90a4b141392834e3b30f452d2ad9399290416894d349726a75d916e2ed48ac53343d4 owncloud-client-2.3.1.tar.gz
+f8210c8cc08e0bfb80e63b18af305c2a8e2309f673caca5bc748c130d960d444ab2db3fad3e43dbfffbe072748c85e15a50d0ebe1fd491dec7553ac8d9552cfe nextcloud-client-2.3.1.tar.gz"