aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-25 02:41:18 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-25 02:42:48 +0200
commit138270d90873b54e7c58f52eb015b4afc37f16cd (patch)
tree519f656750c27370f646a228b23b097c8a544a5e /community/nextcloud
parent09debd9f9820565692f47e22a38fa31e117d9e58 (diff)
downloadaports-138270d90873b54e7c58f52eb015b4afc37f16cd.tar.bz2
aports-138270d90873b54e7c58f52eb015b4afc37f16cd.tar.xz
community/nextcloud: disable integrity check as default
It's unnecessary, APK ensures integrity of all installed files, and problematic (we need to patch some files).
Diffstat (limited to 'community/nextcloud')
-rw-r--r--community/nextcloud/APKBUILD1
-rw-r--r--community/nextcloud/disable-integrity-check-as-default.patch15
2 files changed, 16 insertions, 0 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 56ffa87c8f..200ce0057d 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -17,6 +17,7 @@ subpackages="$pkgname-initscript $pkgname-mysql $pkgname-pgsql $pkgname-sqlite
source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
nextcloud10-dont-chmod-config.patch
dont-update-htaccess.patch
+ disable-integrity-check-as-default.patch
app-encryption-info-add-mcrypt.patch
$pkgname-config.php
$pkgname.logrotate
diff --git a/community/nextcloud/disable-integrity-check-as-default.patch b/community/nextcloud/disable-integrity-check-as-default.patch
new file mode 100644
index 0000000000..87108c600a
--- /dev/null
+++ b/community/nextcloud/disable-integrity-check-as-default.patch
@@ -0,0 +1,15 @@
+We patch some files and Nextcloud's integrity check doesn't like it...
+APK ensures integrity of all installed files, so this Nextcloud's integrity
+check doesn't add any value.
+
+--- a/lib/private/IntegrityCheck/Checker.php
++++ b/lib/private/IntegrityCheck/Checker.php
+@@ -109,7 +109,7 @@ class Checker {
+ * too prominent. So please do not add it to config.sample.php.
+ */
+ if ($this->config !== null) {
+- $isIntegrityCheckDisabled = $this->config->getSystemValue('integrity.check.disabled', false);
++ $isIntegrityCheckDisabled = $this->config->getSystemValue('integrity.check.disabled', true);
+ } else {
+ $isIntegrityCheckDisabled = false;
+ }