aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-25 00:01:58 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-25 02:42:47 +0200
commit65cd9e679154869b92b5c8e2f7f2d7391b02678a (patch)
tree9355f106cbeffdd330b24f8d5783c5127e8ca04c /community/nextcloud
parent56340e0c374f9f287da09df6dbf52894d2ea4861 (diff)
downloadaports-65cd9e679154869b92b5c8e2f7f2d7391b02678a.tar.bz2
aports-65cd9e679154869b92b5c8e2f7f2d7391b02678a.tar.xz
community/nextcloud: remove updater and disable messing w/ htaccess
Diffstat (limited to 'community/nextcloud')
-rw-r--r--community/nextcloud/APKBUILD9
-rw-r--r--community/nextcloud/dont-update-htaccess.patch44
-rw-r--r--community/nextcloud/nextcloud-config.php2
3 files changed, 54 insertions, 1 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 2cb2d4979d..b4254b0e89 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -17,6 +17,7 @@ install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade"
subpackages="$pkgname-doc $pkgname-initscript ${_apps//-/$pkgname-}"
source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
nextcloud10-dont-chmod-config.patch
+ dont-update-htaccess.patch
$pkgname-config.php
$pkgname.logrotate
$pkgname.confd
@@ -45,6 +46,11 @@ package() {
chmod 664 ./$wwwdir/.htaccess \
./$wwwdir/.user.ini
+ # Let's not ship upstream's 'updatenotification' app and updater, which
+ # has zero chance of working and a big chance of blowing things up.
+ rm -r ./$wwwdir/apps/updatenotification \
+ ./$wwwdir/updater
+
install -d -m 770 -o nextcloud -g www-data \
./$confdir ./$datadir ./$basedir/apps
@@ -183,7 +189,8 @@ _mv_app() {
sha512sums="0e409eedbcc0f4e1652085c3e384db373858b0cc116c70361a4d066a08afbd6e75792332f95d08773cbed78c1520532886268249d514f2da70acb3ba120420d5 nextcloud-12.0.0.zip
a12a73a38bc009d3307ce97bb32fc62ac93e125a77a3d36b31c9d2212953fa17bd5c31f819e0759a0645b1c285817b067143b0b9c3673ce4ab3043fae426a67c nextcloud10-dont-chmod-config.patch
-7b54660441fccb60f204a98a6f55dc02ba99a4af159e590a9b380f1d7683b856bfa4c9fc9ee14603cc0923a134e5191bc713b9428d7a8b52017b93aa3c915792 nextcloud-config.php
+ec3921d4d463ed82be0be073af8064048a20f638424d1d39ab46db4252036e87ef2614570be91a5cef0c25c6bcaaf1a2725d2468bdb4a0fbee2b504a4dd0fbc8 dont-update-htaccess.patch
+9df8ea433d9fb5578a2de366106aa9004502a92557970ee48f9f3de92705a623a461eb410666f0e55d46023d0a324cd185a0b51957a1b72992779a0f7143d23d nextcloud-config.php
f224d72799ee5819979089eb58978225454223bee597c938681a4f6279eb49297fe9250ac54ccf8bcb33ae262bce43d085affb77723492ee662263710d4008c9 nextcloud.logrotate
35cf156839215113b5d8fb8842b4c1e19a50be3c16be7048879fdd808674e4875dbacf3e2dd884fd182258595b7a137d7d3c2dc602a7ff5613c8b65fae0abe67 nextcloud.confd
b5cdccdffb35e868ec1acb15ec2849cc1c2a00f6064ad21eb591b9694e84df4576f03248f5e814000a48c38096a2a1588dfc79be66691415f2f4ef3b4105d032 fpm-pool.conf"
diff --git a/community/nextcloud/dont-update-htaccess.patch b/community/nextcloud/dont-update-htaccess.patch
new file mode 100644
index 0000000000..d0e3eb8cc6
--- /dev/null
+++ b/community/nextcloud/dont-update-htaccess.patch
@@ -0,0 +1,44 @@
+Don't mess with .htaccess files.
+
+Patch ported from https://src.fedoraproject.org/cgit/rpms/nextcloud.git/tree/nextcloud-9.1.0-dont_update_htacess.patch
+
+--- a/core/register_command.php
++++ b/core/register_command.php
+@@ -124,7 +125,6 @@
+ $application->add(new OC\Core\Command\Maintenance\Mimetype\UpdateDB(\OC::$server->getMimeTypeDetector(), \OC::$server->getMimeTypeLoader()));
+ $application->add(new OC\Core\Command\Maintenance\Mimetype\UpdateJS(\OC::$server->getMimeTypeDetector()));
+ $application->add(new OC\Core\Command\Maintenance\Mode(\OC::$server->getConfig()));
+- $application->add(new OC\Core\Command\Maintenance\UpdateHtaccess());
+
+ $application->add(new OC\Core\Command\Upgrade(\OC::$server->getConfig(), \OC::$server->getLogger()));
+ $application->add(new OC\Core\Command\Maintenance\Repair(
+--- a/lib/private/Setup.php
++++ b/lib/private/Setup.php
+@@ -387,10 +387,6 @@
+ // out that this is indeed an ownCloud data directory
+ file_put_contents($config->getSystemValue('datadirectory', \OC::$SERVERROOT.'/data').'/.ocdata', '');
+
+- // Update .htaccess files
+- Setup::updateHtaccess();
+- Setup::protectDataDirectory();
+-
+ self::installBackgroundJobs();
+
+ //and we are done
+--- a/lib/private/Updater.php
++++ b/lib/private/Updater.php
+@@ -233,14 +233,6 @@
+ throw new \Exception('Updates between multiple major versions and downgrades are unsupported.');
+ }
+
+- // Update .htaccess files
+- try {
+- Setup::updateHtaccess();
+- Setup::protectDataDirectory();
+- } catch (\Exception $e) {
+- throw new \Exception($e->getMessage());
+- }
+-
+ // create empty file in data dir, so we can later find
+ // out that this is indeed an ownCloud data directory
+ // (in case it didn't exist before)
diff --git a/community/nextcloud/nextcloud-config.php b/community/nextcloud/nextcloud-config.php
index 09a74cf41b..13de237a34 100644
--- a/community/nextcloud/nextcloud-config.php
+++ b/community/nextcloud/nextcloud-config.php
@@ -16,5 +16,7 @@ $CONFIG = array (
'writable' => true,
),
),
+ 'updatechecker' => false,
+ 'check_for_working_htaccess' => false,
'installed' => false,
);