aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-24 16:06:18 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-24 16:02:18 +0200
commitdb80fde0d5e103bf88e82259311ad37afee6bbb0 (patch)
tree637772dd14d08f8d8339b7134668cf453e85cff4 /community/nextcloud
parent07e311959ba49888cff5ae13ebed7a07925f86e8 (diff)
downloadaports-db80fde0d5e103bf88e82259311ad37afee6bbb0.tar.bz2
aports-db80fde0d5e103bf88e82259311ad37afee6bbb0.tar.xz
community/nextcloud: add commented-out config for Redis caching
Diffstat (limited to 'community/nextcloud')
-rw-r--r--community/nextcloud/APKBUILD4
-rw-r--r--community/nextcloud/nextcloud-config.php11
-rw-r--r--community/nextcloud/nextcloud.confd3
3 files changed, 16 insertions, 2 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 88afa90363..ebe43d455e 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -230,9 +230,9 @@ aef3c92497d738d6968e0f0b0d415b4953500db24ae14af41ef972665cf7eff00cb6c53dc953845f
d6f951cbcb7ca48beb88d77e02a8669677e87bc32189b1eb7e63edc29c293bd6e1ee471c37b622e6b38fd2baf6cf198c872f92b256ffab17c92c31a3a05b5aa0 app-encryption-info-add-mcrypt.patch
7d60ba2f1c012b0a1cded30f757b7ec0efe7fc4bfa7b5c6879f35eb80711ac1d5e6c894356346222a0de68b0808c99bac358aaae1c69124a855da2a98cdff6ec iconv-ascii-translit-not-supported.patch
478f5cd7c5d30380ea619d3e8ec623217a06a09b27534266f00297545c7d276b068c5d984673eebc5676e8bac7f45112549498944ce3fa678ac8a69541d7c430 use-external-docs-if-local-not-avail.patch
-89c941e2719629ee633421c4c75b55026c1a0a6b255e7f1f2c14612c10325045051b16dc5f17975af4a2a34ec187008de2eb15a53ac4cd06d26a5cbbd79fb73a nextcloud-config.php
+5f73cd9399fa484ef15bd47e803c93381deffbc7699eceadbb5c27e43b20156806d74e5021a64d28f0165ef87b519e962780651711a37bceb9f0b04455dfdce1 nextcloud-config.php
f224d72799ee5819979089eb58978225454223bee597c938681a4f6279eb49297fe9250ac54ccf8bcb33ae262bce43d085affb77723492ee662263710d4008c9 nextcloud.logrotate
-35cf156839215113b5d8fb8842b4c1e19a50be3c16be7048879fdd808674e4875dbacf3e2dd884fd182258595b7a137d7d3c2dc602a7ff5613c8b65fae0abe67 nextcloud.confd
+dcc57735d7d4af4a7ebbdd1186d301e51d2ae4675022aea6bf1111222dfa188a3a490ebd6e7c8a7ac30046cb7d93f81cec72a51acbc60d0c10b7fb64630c637a nextcloud.confd
edb699ea6127b231793254115b334006c2d50a0d2ecc846188c3521ddffc3c0e19c5e2944f03cae81e6c645c859258380691081b1c522a22d40939b31db36e8a nextcloud.cron
ee9073a6df4286cba2d1d855cf40863968f20677729b2c7848ab50a70d4915b8e84c957a850a03a707231256c11312e5792e7817dd50afbf73efe767fef2112d fpm-pool.conf
959852e34f010e635470829d66713f3e22c47717ec2c6487759eed2b6aeff9fd1421fe0271d494a02781bd1c98beb2823583623ee2cf03057cd5db794627d6c2 occ"
diff --git a/community/nextcloud/nextcloud-config.php b/community/nextcloud/nextcloud-config.php
index de572edc28..035fb790ec 100644
--- a/community/nextcloud/nextcloud-config.php
+++ b/community/nextcloud/nextcloud-config.php
@@ -22,5 +22,16 @@ $CONFIG = array (
// Uncomment to enable Zend OPcache.
//'memcache.local' => '\OC\Memcache\APCu',
+ // Uncomment this and add user nextcloud to the redis group to enable Redis
+ // cache for file locking. This is highly recommended, see
+ // https://github.com/nextcloud/server/issues/9305.
+ //'memcache.locking' => '\OC\Memcache\Redis',
+ //'redis' => array(
+ // 'host' => '/run/redis/redis.sock',
+ // 'port' => 0,
+ // 'dbindex' => 0,
+ // 'timeout' => 1.5,
+ //),
+
'installed' => false,
);
diff --git a/community/nextcloud/nextcloud.confd b/community/nextcloud/nextcloud.confd
index aae73dc2f3..b24f26d7f1 100644
--- a/community/nextcloud/nextcloud.confd
+++ b/community/nextcloud/nextcloud.confd
@@ -3,3 +3,6 @@
name="Nextcloud"
user="nextcloud"
group="www-data"
+
+# Uncomment if you use Nextcloud with Redis for caching.
+#rc_need="redis"