aboutsummaryrefslogtreecommitdiffstats
path: root/community/nnn/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:41:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:44:47 +0200
commite25c15766f5a036de0fc7290cba7b98ef41b46ec (patch)
tree7dec8170db73d5e18cb14f3482153d6f72086ae2 /community/nnn/APKBUILD
parent118a78fe94b503a7e21c98c71fc0e6c3d76373e3 (diff)
downloadaports-e25c15766f5a036de0fc7290cba7b98ef41b46ec.tar.bz2
aports-e25c15766f5a036de0fc7290cba7b98ef41b46ec.tar.xz
community/nnn: move from testing
Diffstat (limited to 'community/nnn/APKBUILD')
-rw-r--r--community/nnn/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/nnn/APKBUILD b/community/nnn/APKBUILD
new file mode 100644
index 0000000000..421a1b8928
--- /dev/null
+++ b/community/nnn/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=nnn
+pkgver=1.7
+pkgrel=1
+pkgdesc="The missing terminal file browser for X"
+url="https://github.com/jarun/nnn"
+arch="all !armhf" # armhf: fails to build
+license="BSD-2-Clause"
+makedepends="ncurses-dev readline-dev"
+options="!check" # no tests provided and `nnn -v` requires tty
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jarun/$pkgname/archive/v$pkgver.tar.gz
+ nlay"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+
+ # Overwrite the provided nlay script with our POSIX compliant version.
+ install -m 755 "$srcdir"/nlay "$pkgdir"/usr/bin/nlay
+}
+
+sha512sums="7574971b423a1c49e2217d5e4415a69536b807587b4e32b61568ce0c6a1734ed85924a3ef68027653f1f0e882ef8df1bc375e119a9ded51e133a2adf5cd560cb nnn-1.7.tar.gz
+9f70f5fec2799caf1624e1334e687072dde94ee550a4cd7ee5a1a6b9b880f3fe40b6cbd631ce2d024cb811b5115249e7cd81c880c88f2289f627cd866fc06036 nlay"