aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-23 13:01:09 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-23 13:10:29 +0200
commit7b2ac1850d39f7592fac3115fc9c4cc803c3ff24 (patch)
tree43b47479ec1b4d7fe65a060e7d4cd59193f6014c /community/nodejs-current
parentcd55ebfffa68f180e6883c802c49f9f077c019a1 (diff)
downloadaports-7b2ac1850d39f7592fac3115fc9c4cc803c3ff24.tar.bz2
aports-7b2ac1850d39f7592fac3115fc9c4cc803c3ff24.tar.xz
community/nodejs-current: modernize abuild
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 0bd26fb085..24a962789e 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -22,7 +22,7 @@ source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
builddir="$srcdir/node-v$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
# Remove bundled dependencies that we're not using.
rm -rf deps/http_parser deps/openssl deps/uv deps/zlib
@@ -37,25 +37,24 @@ build() {
--shared-openssl \
--shared-http-parser \
--shared-cares \
- --openssl-use-def-ca-store \
- || return 1
+ --openssl-use-def-ca-store
- # we need run mksnapshot at build time so paxmark it early
- make -C out mksnapshot BUILDTYPE=Release \
- && paxmark -m out/Release/mksnapshot \
- && make || return 1
+ # we need run mksnapshot at build time so paxmark it early.
+ make -C out mksnapshot BUILDTYPE=Release
+ paxmark -m out/Release/mksnapshot
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# paxmark so JIT works
- paxmark -m "$pkgdir"/usr/bin/node || return 1
+ paxmark -m "$pkgdir"/usr/bin/node
- cp -pr "$pkgdir"/usr/lib/node_modules/npm/man "$pkgdir"/usr/share || return 1
+ cp -pr "$pkgdir"/usr/lib/node_modules/npm/man "$pkgdir"/usr/share
local d; for d in doc html man; do
- rm -r "$pkgdir"/usr/lib/node_modules/npm/$d || return 1
+ rm -r "$pkgdir"/usr/lib/node_modules/npm/$d
done
}
@@ -66,7 +65,7 @@ npm() {
replaces="nodejs-npm $pkgname" # $pkgname for backward compatibility
mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/npm "$subpkgdir"/usr/bin/ || return 1
+ mv "$pkgdir"/usr/bin/npm "$subpkgdir"/usr/bin/
mkdir -p "$subpkgdir"/usr/lib/node_modules
mv "$pkgdir"/usr/lib/node_modules/npm "$subpkgdir"/usr/lib/node_modules/