aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-17 18:10:14 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-17 18:12:29 +0200
commit880802e840fe8cc9867aec0412157f38d52c03ca (patch)
treeee2b3019342c99835669e71a8a86ce73a57025b1 /community/nodejs-current
parent179bdd31daa25b50c834f9bdcd8a06878fa9dde4 (diff)
downloadaports-880802e840fe8cc9867aec0412157f38d52c03ca.tar.bz2
aports-880802e840fe8cc9867aec0412157f38d52c03ca.tar.xz
community/nodejs-current: upgrade to 8.7.0
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD10
-rw-r--r--community/nodejs-current/ppc-fix-musl-mcontext.patch32
2 files changed, 4 insertions, 38 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 8055d0647f..b1d2f8c131 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jose-Luis Rivas <ghostbar@riseup.net>
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=8.6.0
+pkgver=8.7.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="http://nodejs.org/"
@@ -17,8 +17,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-npm::noarch"
provides="nodejs"
replaces="nodejs nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
- dont-run-gyp-files-for-bundled-deps.patch
- ppc-fix-musl-mcontext.patch"
+ dont-run-gyp-files-for-bundled-deps.patch"
builddir="$srcdir/node-v$pkgver"
prepare() {
@@ -83,6 +82,5 @@ npm() {
mv "$pkgdir"/usr/lib/node_modules/npm "$subpkgdir"/usr/lib/node_modules/
}
-sha512sums="f51cb57acbbbd8c34a10b1bd5a9bccda38227d486838091f337389d148f4ff54041786875842dadd0c0a7bc2ee7e00f83bd8f28b98ca0f348eaa6b24a5d34b47 node-v8.6.0.tar.gz
-ba95f21b1e80717ef63941854e7ed412f64a91da068c0dbf0d6d9697333ee266c9f4cd7bf1a01111eeb28aa66adefd8a58cfb3e82debb84b43e35e9dc914dd36 dont-run-gyp-files-for-bundled-deps.patch
-fba595afa968810a705c0c5794329e888e2ff78b797861b80aa6f021c27770ea716cda544962cbf0abf4ba152eeee7869b58f1b042ed9b3f543c63f527c569a2 ppc-fix-musl-mcontext.patch"
+sha512sums="0214f2624c67fb2d96f35f3520487865922bf4673fea6890c10479580743bb915d06d9bdc4b1ee2bfcf46240f752ff6d0ed9839fb5bcc3f3cb60e7caf33758be node-v8.7.0.tar.gz
+ba95f21b1e80717ef63941854e7ed412f64a91da068c0dbf0d6d9697333ee266c9f4cd7bf1a01111eeb28aa66adefd8a58cfb3e82debb84b43e35e9dc914dd36 dont-run-gyp-files-for-bundled-deps.patch"
diff --git a/community/nodejs-current/ppc-fix-musl-mcontext.patch b/community/nodejs-current/ppc-fix-musl-mcontext.patch
deleted file mode 100644
index bfda4b6db7..0000000000
--- a/community/nodejs-current/ppc-fix-musl-mcontext.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From: Gustavo Romero <gromero@br.ibm.com>
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Mon, 28 Mar 2017 01:51:00 +0200
-Subject: [PATCH] Fix compilation on PPC when libc musl is used instead of glibc
-
-Musl on Power does not define regs member as a pt_regs pointer type,
-hence it's necessary to use member gp_regs instead.
-
-Ported to nodejs 7.7.4 (jirutka)
-
---- a/deps/v8/src/libsampler/sampler.cc
-+++ b/deps/v8/src/libsampler/sampler.cc
-@@ -450,11 +450,19 @@
- state->sp = reinterpret_cast<void*>(mcontext.gregs[29]);
- state->fp = reinterpret_cast<void*>(mcontext.gregs[30]);
- #elif V8_HOST_ARCH_PPC
-+#if V8_LIBC_GLIBC
- state->pc = reinterpret_cast<void*>(ucontext->uc_mcontext.regs->nip);
- state->sp =
- reinterpret_cast<void*>(ucontext->uc_mcontext.regs->gpr[PT_R1]);
- state->fp =
- reinterpret_cast<void*>(ucontext->uc_mcontext.regs->gpr[PT_R31]);
-+#else
-+ // Some C libraries, notably Musl, define the regs member as a void pointer,
-+ // hence we use the gp_regs member instead.
-+ state->pc = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[32]);
-+ state->sp = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[1]);
-+ state->fp = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[31]);
-+#endif
- #elif V8_HOST_ARCH_S390
- #if V8_TARGET_ARCH_32_BIT
- // 31-bit target will have bit 0 (MSB) of the PSW set to denote addressing