aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authorGustavo Romero <gromero@br.ibm.com>2017-04-12 20:14:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-13 10:19:43 +0000
commitc68ee6d892b60cd77149f5bdbf3041c35f294e30 (patch)
tree497dcd3f5f8c52e397b0b9081a1f96cd69dafaf3 /community/nodejs-current
parent418e58768276071bd405376dba2732cab7355343 (diff)
downloadaports-c68ee6d892b60cd77149f5bdbf3041c35f294e30.tar.bz2
aports-c68ee6d892b60cd77149f5bdbf3041c35f294e30.tar.xz
community/nodejs-current: update ppc patch to fit sampler
Update ppc patch due to a refactor in sampler.cc internals introduced in [1] where 'state' variable is now treated as a pointer. [1] https://goo.gl/YwyjCC
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD2
-rw-r--r--community/nodejs-current/ppc-fix-musl-mcontext.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 51956138b9..0b91584f35 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -73,4 +73,4 @@ npm() {
sha512sums="38ae9a8084ab5f20d895b8f2fb6c4f010789f5c01a05f3260ab290d85c3e7c00b79c0f412a3f1ca2bc2e3bd0d644146a7455fdcd384b532bb56cf16e9ad2bca3 node-v7.9.0.tar.gz
ba95f21b1e80717ef63941854e7ed412f64a91da068c0dbf0d6d9697333ee266c9f4cd7bf1a01111eeb28aa66adefd8a58cfb3e82debb84b43e35e9dc914dd36 dont-run-gyp-files-for-bundled-deps.patch
-a128c76c6e5cc4d0c168bef1d02f10d1ce6be9ae98d92d4284c75e0f39bdf02355c1ac37996b749c1fda95bdffc273b0a10546f9ebfc5f02b8bc2cf5ac79981b ppc-fix-musl-mcontext.patch"
+fba595afa968810a705c0c5794329e888e2ff78b797861b80aa6f021c27770ea716cda544962cbf0abf4ba152eeee7869b58f1b042ed9b3f543c63f527c569a2 ppc-fix-musl-mcontext.patch"
diff --git a/community/nodejs-current/ppc-fix-musl-mcontext.patch b/community/nodejs-current/ppc-fix-musl-mcontext.patch
index 640fb8ed05..bfda4b6db7 100644
--- a/community/nodejs-current/ppc-fix-musl-mcontext.patch
+++ b/community/nodejs-current/ppc-fix-musl-mcontext.patch
@@ -23,9 +23,9 @@ Ported to nodejs 7.7.4 (jirutka)
+#else
+ // Some C libraries, notably Musl, define the regs member as a void pointer,
+ // hence we use the gp_regs member instead.
-+ state.pc = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[32]);
-+ state.sp = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[1]);
-+ state.fp = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[31]);
++ state->pc = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[32]);
++ state->sp = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[1]);
++ state->fp = reinterpret_cast<void*>(ucontext->uc_mcontext.gp_regs[31]);
+#endif
#elif V8_HOST_ARCH_S390
#if V8_TARGET_ARCH_32_BIT