aboutsummaryrefslogtreecommitdiffstats
path: root/community/numix-themes
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-08-18 20:46:53 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:24:04 +0200
commit5c9f3ca3e307be53b45beeed2ce1626f38008625 (patch)
tree919836fe454e953f46685adf8228b0401280d4b6 /community/numix-themes
parent6a00a953ba02bab6440a2c784e7db37c6eaeace1 (diff)
downloadaports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.bz2
aports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.xz
testing/[various]: move to community
albatross-themes apk-post-messages autossh bitcoin btrbk entr ffmpegthumbnailer firejail firetools fwsnort gnome-colors imapsync inetutils-syslogd inotify-tools-inc isync junit ktsuss letsencrypt-nosudo libmbim libndp libqmi libteam mini-sendmail modemmanager namecoin networkmanager nginx-naxsi numix-themes nxapi opencl-headers opencl-icd-loader opus-tools perl-authen-ntlm perl-bit-vector perl-data-uniqid perl-file-copy-recursive perl-getopt-argvfile perl-io-tee perl-iptables-chainmgr perl-iptables-parse perl-module-scandeps perl-par-dist perl-par-packer perl-par perl-uri-escape psad py-crcmod py-graphviz py-lz4 py-opencl py-opengl-accelerate runit secpwgen secure-delete socklog spacefm tinyssh udevil virt-viewer virtualbricks whois wrk xpra zram-init
Diffstat (limited to 'community/numix-themes')
-rw-r--r--community/numix-themes/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/numix-themes/APKBUILD b/community/numix-themes/APKBUILD
new file mode 100644
index 0000000000..16d3c941a2
--- /dev/null
+++ b/community/numix-themes/APKBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=numix-themes
+_pkgname=numix-gtk-theme
+pkgver=2.6.1
+pkgrel=0
+pkgdesc="A modern flat theme with a combination of light and dark elements, GTK 2 and 3"
+url="http://shimmerproject.org/project/Numix/"
+arch="noarch"
+license="GPLv3"
+makedepends="$depends_dev"
+subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4 $pkgname-xfce4-notifyd:_notify
+ $pkgname-openbox:_openbox"
+source="numix-$pkgver.tar.gz::https://github.com/numixproject/$_pkgname/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ # Remove Unity theme
+ rm -f gtk-3.0/apps/unity.css
+ sed -i '/unity\.css/d' gtk-3.0/gtk.css
+ rm -rf unity
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/themes/Numix
+ cp -pr * "$pkgdir"/usr/share/themes/Numix
+ rm -f "$pkgdir"/usr/share/themes/Numix/Makefile
+}
+
+_mv() {
+ pkgdesc="$1"
+ install_if="$pkgname=$pkgver-r$pkgrel $2";
+ depends=
+ local _i
+ shift; shift
+ mkdir -p "$subpkgdir"/usr/share/themes/Numix
+ for _i; do
+ msg "moving $_i"
+ mv "$pkgdir"/usr/share/themes/Numix/$_i \
+ "$subpkgdir"/usr/share/themes/Numix || return 1
+ done
+}
+
+gtk2() {
+ _mv "Numix GTK2 themes" gtk2.0 gtk-2.0
+ depends="gtk-murrine-engine"
+}
+
+gtk3() { _mv "Numix GTK3 themes" gtk3.0 gtk-3.*; }
+metacity() { _mv "Numix Metacity themes" metacity metacity-1; }
+xfwm4() { _mv "Numix Xfce4 themes" xfwm4 xfwm4; }
+_notify() { _mv "Numix Xfce4-notifyd themes" xfce4-notifyd xfce-notify-4.0; }
+_openbox() { _mv "Numix openbox themes" openbox openbox-3; }
+
+md5sums="499e2e8e9d7d1d81403ebf8f65c8ced6 numix-2.6.1.tar.gz"
+sha256sums="7d81fb0fe7a50f933ae8016154a6da8ea4f6c12d988f735db277424af344a5bf numix-2.6.1.tar.gz"
+sha512sums="ebdbf20049b84141b10bafa93685f844b59ae629d19ede0eef44afafa18357cb54d66cb830a67bf09ab251b04dbf21193e7bc5ea19124061d7fd8dbf4538a745 numix-2.6.1.tar.gz"