aboutsummaryrefslogtreecommitdiffstats
path: root/community/nx-libs
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-05 11:49:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-05 11:51:01 +0000
commit2b720e0eee7ab9266f33e1452093f4b70dd0eec6 (patch)
tree1396926ef5b517206e11ed33d438d744db37e053 /community/nx-libs
parent8e5ae508bdc5c7903bd7c875af8e5f652895f597 (diff)
downloadaports-2b720e0eee7ab9266f33e1452093f4b70dd0eec6.tar.bz2
aports-2b720e0eee7ab9266f33e1452093f4b70dd0eec6.tar.xz
community/nx-libs: upgrade to 3.5.0.32, moved from testing
Diffstat (limited to 'community/nx-libs')
-rw-r--r--community/nx-libs/APKBUILD40
-rw-r--r--community/nx-libs/Makefile.patch11
-rw-r--r--community/nx-libs/fix-musl-headers-x86.patch11
-rw-r--r--community/nx-libs/xf86bigfont.patch11
4 files changed, 73 insertions, 0 deletions
diff --git a/community/nx-libs/APKBUILD b/community/nx-libs/APKBUILD
new file mode 100644
index 0000000000..6dda4b8913
--- /dev/null
+++ b/community/nx-libs/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jean-Charles de Longueville <jch@hellea.eu>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=nx-libs
+pkgver=3.5.0.32
+pkgrel=0
+pkgdesc="NoMachine libraries (redistributed by x2go)"
+url="http://x2go.org"
+arch="all"
+license="GPLv2+"
+depends="font-cursor-misc font-misc-misc"
+makedepends="libx11-dev zlib-dev libjpeg-turbo-dev
+ libpng-dev libfontenc-dev linux-headers
+ libxml2-dev bash automake autoconf"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://code.x2go.org/releases/source/$pkgname/$pkgname-$pkgver-full.tar.gz
+ xf86bigfont.patch
+ fix-musl-headers-x86.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$builddir"
+ #Every Makefile has /usr/local as PREFIX, so replace that
+ sed -i -e 's,/usr/local,/usr,' nx-X11/config/cf/site.def
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ make -j1 PREFIX=/usr USRLIBDIR=/usr/lib SHLIBDIR=/usr/lib CONFIGURE="./configure --prefix=/usr --libdir=/usr/lib --includedir=/usr/include" || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" USRLIBDIR=/usr/lib SHLIBDIR=/usr/lib install CONFIGURE="./configure --prefix=/usr --libdir=/usr/lib --includedir=/usr/include" || return 1
+}
+
+sha512sums="8b4a042993d45e1aee3e13e8b86f68cd5b2a8b52e9299de6129abd8e3bb89d73cf2b44b03d3c7fabbd8329abc06dc912ac95bbf936b6478b05fc202cc29a090f nx-libs-3.5.0.32-full.tar.gz
+ee090f4e7f5933cbea6398ac461539cbdc8b7fd62f32934c78298c1e217d2a60e7f796bffdb88d36816bbfa9becd810846f5b988b5191e5a5b9da5def5d730fa xf86bigfont.patch
+d4a881b66f0258d6d9fb947a526868944e58217d534316dfa3f0837035415467a1e8841bf6c5b821ccedcc0c9e07b425f05243ddbd22aaec7ea2165c87d9211e fix-musl-headers-x86.patch"
diff --git a/community/nx-libs/Makefile.patch b/community/nx-libs/Makefile.patch
new file mode 100644
index 0000000000..35037d4f81
--- /dev/null
+++ b/community/nx-libs/Makefile.patch
@@ -0,0 +1,11 @@
+--- nx-libs-3.5.0.28/Makefile
++++ ../Makefile
+@@ -14,7 +14,7 @@
+ BINDIR=$(PREFIX)/bin
+ NXLIBDIR=$(PREFIX)/lib/nx
+ X2GOLIBDIR=$(PREFIX)/lib/x2go
+-CONFIGURE ?= ./configure
++CONFIGURE ?= ./configure --prefix=usr
+
+ SHELL:=/bin/bash
+
diff --git a/community/nx-libs/fix-musl-headers-x86.patch b/community/nx-libs/fix-musl-headers-x86.patch
new file mode 100644
index 0000000000..3f51b8e4b1
--- /dev/null
+++ b/community/nx-libs/fix-musl-headers-x86.patch
@@ -0,0 +1,11 @@
+--- ./nx-X11/extras/Mesa/src/mesa/main/glheader.h.orig
++++ ./nx-X11/extras/Mesa/src/mesa/main/glheader.h
+@@ -62,7 +62,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+-#if defined(__linux__) && defined(__i386__)
++#if defined(__GLIBC__) && defined(__i386__)
+ #include <fpu_control.h>
+ #endif
+ #endif
diff --git a/community/nx-libs/xf86bigfont.patch b/community/nx-libs/xf86bigfont.patch
new file mode 100644
index 0000000000..94578dd778
--- /dev/null
+++ b/community/nx-libs/xf86bigfont.patch
@@ -0,0 +1,11 @@
+--- nx-libs-3.5.0.28/nx-X11/programs/Xserver/Xext/xf86bigfont.c
++++ ../xf86bigfont.c
+@@ -46,7 +46,7 @@
+ /* Linux libc4 and libc5 only (because glibc doesn't include kernel headers):
+ Linux 2.0.x and 2.2.x define SHMLBA as PAGE_SIZE, but forget to define
+ PAGE_SIZE. It is defined in <asm/page.h>. */
+-#include <asm/page.h>
++#include <limits.h>
+ #endif
+ #ifdef SVR4
+ #include <sys/sysmacros.h>