aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk8
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-09 11:41:23 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-09 11:41:23 +0000
commit8fddb2b8636b0d7c158df067bc26dea13df4ff09 (patch)
tree16d08945044329670f31075f95a2d794892dc643 /community/openjdk8
parentb1f3e812d7ad4e21c3c109a2d5e44a8cf3d70add (diff)
downloadaports-8fddb2b8636b0d7c158df067bc26dea13df4ff09.tar.bz2
aports-8fddb2b8636b0d7c158df067bc26dea13df4ff09.tar.xz
community/openjdk8: fix paxmarking
- fix the script to work with split subpkg directory layout - make apkbuild abort on marking error - rebuild with new abuild that has xattr issue fixed
Diffstat (limited to 'community/openjdk8')
-rw-r--r--community/openjdk8/APKBUILD10
-rw-r--r--community/openjdk8/fix-paxmark.patch28
2 files changed, 35 insertions, 3 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 0ead5f7b82..201f85b250 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -53,6 +53,7 @@ source="http://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.gz
langtools-$_dropsver.tar.xz::$_dropsurl/langtools.tar.xz
hotspot-$_dropsver.tar.xz::$_dropsurl/hotspot.tar.xz
nashorn-$_dropsver.tar.xz::$_dropsurl/nashorn.tar.xz
+ fix-paxmark.patch
icedtea-hotspot-musl.patch
icedtea-hotspot-noagent-musl.patch
@@ -160,7 +161,7 @@ package() {
rm "$pkgdir"/$_jrelib/server/classes.jsa
# pax mark again (due to fakeroot xattr handling bug)
- ./pax-mark-vm "$pkgdir"/$_java_home
+ ./pax-mark-vm "$pkgdir"/$_java_home true || return 1
# symlink to shared java cacerts store
rm -f "$pkgdir"/$_java_home/jre/lib/security/cacerts
@@ -208,7 +209,7 @@ jre() {
done
# Pax mark again (due to fakeroot xattr handling bug).
- "$builddir"/pax-mark-vm "$subpkgdir"/$_java_home
+ "$builddir"/pax-mark-vm "$subpkgdir"/$_java_home true || return 1
}
jrebase() {
@@ -230,7 +231,7 @@ jrebase() {
mv "$pkgdir"/$_java_home/jre "$subpkgdir"/$_java_home/ || return 1
# Pax mark again (due to fakeroot xattr handling bug).
- "$builddir"/pax-mark-vm "$subpkgdir"/$_java_home
+ "$builddir"/pax-mark-vm "$subpkgdir"/$_java_home true || return 1
}
doc() {
@@ -258,6 +259,7 @@ md5sums="eb6fc764df734e284cb485de909d7a31 icedtea-3.3.0.tar.gz
b10431e5823ac859de631e183b1d0b67 langtools-3.3.0.tar.xz
e600f285d00ee367b4129450c35f113a hotspot-3.3.0.tar.xz
9cc3887801b7ad6c290c4adf4a742130 nashorn-3.3.0.tar.xz
+5ac9306bf404251111cee6b9eff26bd4 fix-paxmark.patch
2f4a5b0ec7a2bf7ab609da10b86dca4c icedtea-hotspot-musl.patch
bd148291e75d536972cb2b1b68e5cb05 icedtea-hotspot-noagent-musl.patch
43023861c5f6efc3139a834aa3ec0476 icedtea-hotspot-uclibc-fixes.patch
@@ -276,6 +278,7 @@ a443f3243978a87a055ab103468878e5e072706ab0c82d1949ba869fc63571b6 jaxws-3.3.0.ta
1b0b0fb49c81955573ce509e1801530faa6477e606192fec4b0f951904fb8ac0 langtools-3.3.0.tar.xz
280f706bb0aaada0903e9e907811ea12bc1c216fdaeb2694910f3a99217f6e89 hotspot-3.3.0.tar.xz
0ec045c9c4506f63602d86e72b0c3fdccd75fa95c47ee6a1238639274dc8e92d nashorn-3.3.0.tar.xz
+79bff0b02da899cdc14040443f254a742bdd599ca21357e6c28a4ec35da0e2ac fix-paxmark.patch
ed114e8d00d6ed1295f5995df02ad13d3d0cd242f7a904600d93b6564856f8df icedtea-hotspot-musl.patch
c14529a29bfdfb51bf5b4a41c977039073f470758e31235d043d373b48d46a11 icedtea-hotspot-noagent-musl.patch
0ef7592b8f2c954eda0a6cf4dc4a4010942f35ea426f44e34412be6c9a949745 icedtea-hotspot-uclibc-fixes.patch
@@ -294,6 +297,7 @@ b1f44e1e41b3565bd45176f726e4d1c2999c5ff25a5f2e973f0e5836b7fd2cf6540eae83d3944b30
13065b54ca036ad11b8879d9ebaa725a823c25cda5b28f0092902bda2b8879cfd000d132916302f2661b63b03c0bec90d1adfe4863d38c201cfbdf74f1f942c6 langtools-3.3.0.tar.xz
8a593b1c9f022e7a3efa834c5547c59f1a2143f946edae2647a3368f9d4d39b9d473f36575d395e627e5bfac1f9cdef0efe607e0a81b40c46dca44ad6d59a65b hotspot-3.3.0.tar.xz
c0aec36e921288b6ad11e71daa32111a4ee45302a2bbe407229cc143f05869372993f7b0dd366c07ecb31fac47e1d3cdb0c59cc1a48375d3719656c2159fee95 nashorn-3.3.0.tar.xz
+1f470432275d5beaa8b4e4352a2f24a4a00593546dc4f3bd857794c89e521e8e6d6abc540762bbd769be3e1e3da058e134dc5dc066d12b9b8a1f0656040a795c fix-paxmark.patch
ada3bc4024682bfb86ebf3850d3a36cf4c0f0677a6d56eac2e0959b92bfe759010d5b9c801b043cae3ca8418d7819546ae245ac163df83e48c5d4b34478daeb0 icedtea-hotspot-musl.patch
3c592a14f1806a431290a96a8c1413ca1cc621e73a87ed778fa98878c82809bd924072210d4e4127a6c0c32ff557d749f6c9b3ce31cbca083b013240b618b224 icedtea-hotspot-noagent-musl.patch
822eee0dc4d3ba677a289dfeb3668b536d2d626708390a9d9702fb4144a481fd443a215a0d2041c6026113837aafa4ba0b5e9ead8589d2da6717a238bbc95a5a icedtea-hotspot-uclibc-fixes.patch
diff --git a/community/openjdk8/fix-paxmark.patch b/community/openjdk8/fix-paxmark.patch
new file mode 100644
index 0000000000..2c43014322
--- /dev/null
+++ b/community/openjdk8/fix-paxmark.patch
@@ -0,0 +1,28 @@
+--- icedtea-3.3.0/pax-mark-vm.in.orig 2017-02-09 09:42:32.652307034 +0000
++++ icedtea-3.3.0/pax-mark-vm.in 2017-02-09 09:43:46.043633914 +0000
+@@ -9,17 +9,15 @@
+ }
+
+ if test "x@PAX_COMMAND@" != "x"; then
+- if @PAX_COMMAND@ -m "${JDK}"/bin/java; then
+ for paxable in `list_paxables "${JDK}"/bin/* "${JDK}"/jre/bin/*`; do
+ echo "PaX mark @PAX_COMMAND_ARGS@ ${paxable}"
+- @PAX_COMMAND@ @PAX_COMMAND_ARGS@ "${paxable}"
++ if ! @PAX_COMMAND@ @PAX_COMMAND_ARGS@ "${paxable}"; then
++ if test "x${FAIL_ON_ERROR}" = "xtrue"; then
++ echo "ERROR: Could not apply PaX markings to files in ${JDK}";
++ exit 1;
++ else
++ echo "WARNING: Could not apply PaX markings to files in ${JDK}";
++ fi
++ fi
+ done
+- else
+- if test "x${FAIL_ON_ERROR}" = "xtrue"; then
+- echo "ERROR: Could not apply PaX markings to files in ${JDK}";
+- exit 1;
+- else
+- echo "WARNING: Could not apply PaX markings to files in ${JDK}";
+- fi
+- fi
+ fi