aboutsummaryrefslogtreecommitdiffstats
path: root/community/openlibm
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-10-22 08:04:40 -0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-23 12:21:12 +0200
commita0068f8a9b10f708a164c4f1312e48fd3c13fce9 (patch)
treee819956e845252879cd1d591859cb93e8bea0191 /community/openlibm
parent172c0bd3e6c3e2b6dab46dae04008d430f0d44a5 (diff)
downloadaports-a0068f8a9b10f708a164c4f1312e48fd3c13fce9.tar.bz2
aports-a0068f8a9b10f708a164c4f1312e48fd3c13fce9.tar.xz
community/openlibm: upgrade to 0.5.5
Diffstat (limited to 'community/openlibm')
-rw-r--r--community/openlibm/APKBUILD6
-rw-r--r--community/openlibm/aarch64_fixes.patch65
2 files changed, 69 insertions, 2 deletions
diff --git a/community/openlibm/APKBUILD b/community/openlibm/APKBUILD
index 5c89b59b03..658ef843d9 100644
--- a/community/openlibm/APKBUILD
+++ b/community/openlibm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=openlibm
-pkgver=0.5.4
+pkgver=0.5.5
pkgrel=0
pkgdesc="High quality system independent, portable, open source libm implementation"
url="http://www.openlibm.org"
@@ -11,6 +11,7 @@ depends=""
makedepends=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$pkgname/archive/v$pkgver.tar.gz
+ aarch64_fixes.patch
powerpc_fixes.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -24,5 +25,6 @@ package() {
make VERSION=$pkgver DESTDIR="$pkgdir" prefix=/usr install
}
-sha512sums="ca74936b9eb7a52566cc509ffb98dd9e1672cd4029ba0193162505e53fe671b8903c37ef4036c15d0872ca246079a792d1630f3a93024010ff0c232f78295192 openlibm-0.5.4.tar.gz
+sha512sums="d9e441f177bc7af087c179e9cd1e6bcd98054f19b68e701cf5f6e4518523ed9a69c54ca7c77903031432c13c6e302439c5b74040e9ffa29b52c47978fa5ca662 openlibm-0.5.5.tar.gz
+dd34aef4a1e260305f9e42443b3c1e3fa046c1174346ad449f99deebef3ded6530b03d3b7a210e0acde5a33bb95a0541a0e13cd26c9d82127e05824b811acfc1 aarch64_fixes.patch
76ee57a281275b2bd382f0485e4ca383566af47f3d89981b75ad764c629d82f7f0260fb41cc9eb50f0f175c88b64699aabcc732add321f4d730f38ba7a48238d powerpc_fixes.patch"
diff --git a/community/openlibm/aarch64_fixes.patch b/community/openlibm/aarch64_fixes.patch
new file mode 100644
index 0000000000..4fc7b0fb2a
--- /dev/null
+++ b/community/openlibm/aarch64_fixes.patch
@@ -0,0 +1,65 @@
+From 238a90959fff053458767dd16f193204869387c0 Mon Sep 17 00:00:00 2001
+From: Yichao Yu <yyc1992@gmail.com>
+Date: Sat, 21 Oct 2017 09:50:50 -0400
+Subject: [PATCH] Fix compilation on AArch64
+
+The 128bit double directory is missing and was never used....
+---
+ Make.inc | 6 +++++-
+ Makefile | 5 +++++
+ ld128/Make.files | 14 +++++++++++++-
+ 3 files changed, 23 insertions(+), 2 deletions(-)
+
+diff --git a/Make.inc b/Make.inc
+index db84d07..b1d43a7 100644
+--- a/Make.inc
++++ b/Make.inc
+@@ -125,8 +125,12 @@ SFLAGS_add += $(SFLAGS_arch)
+ LDFLAGS_add += $(LDFLAGS_arch)
+
+ CFLAGS_add += -std=c99 -Wall -I$(OPENLIBM_HOME) -I$(OPENLIBM_HOME)/include -I$(OPENLIBM_HOME)/$(ARCH) -I$(OPENLIBM_HOME)/src -DASSEMBLER -D__BSD_VISIBLE -Wno-implicit-function-declaration
+-ifneq ($(filter $(ARCH),i387 amd64 aarch64 powerpc),)
++ifneq ($(filter $(ARCH),i387 amd64 powerpc),)
+ CFLAGS_add += -I$(OPENLIBM_HOME)/ld80
++else
++ifneq ($(filter $(ARCH),aarch64),)
++CFLAGS_add += -I$(OPENLIBM_HOME)/ld128
++endif
+ endif
+
+
+diff --git a/Makefile b/Makefile
+index 1834610..e4324a9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -5,6 +5,11 @@ SUBDIRS = src $(ARCH) bsdsrc
+ # Add ld80 directory on x86 and x64
+ ifneq ($(filter $(ARCH),i387 amd64),)
+ SUBDIRS += ld80
++else
++ifneq ($(filter $(ARCH),aarch64),)
++SUBDIRS += ld128
++else
++endif
+ endif
+
+ define INC_template
+diff --git a/ld128/Make.files b/ld128/Make.files
+index 0eab034..1198cfb 100644
+--- a/ld128/Make.files
++++ b/ld128/Make.files
+@@ -1 +1,13 @@
+-SRCS = invtrig.c k_cosl.c k_sinl.c k_tanl.c # s_nanl.c s_exp2l.c
++$(CUR_SRCS) += invtrig.c \
++ e_acoshl.c e_powl.c k_tanl.c s_exp2l.c \
++ e_atanhl.c e_lgammal_r.c e_sinhl.c s_asinhl.c s_expm1l.c \
++ e_coshl.c e_log10l.c e_tgammal.c \
++ e_expl.c e_log2l.c k_cosl.c s_log1pl.c s_tanhl.c \
++ e_logl.c k_sinl.c s_erfl.c
++
++# s_remquol.c e_fmodl.c s_truncl.c
++# e_hypotl.c s_floorl.c s_nextafterl.c s_ceill.c s_modfl.c
++
++ifneq ($(OS), WINNT)
++$(CUR_SRCS) += s_nanl.c
++endif