aboutsummaryrefslogtreecommitdiffstats
path: root/community/openlibm
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-08 23:55:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-08 23:47:58 +0200
commitbe26f5cfd9c51d74dece7f0655b793d31381cd0d (patch)
tree65418087a789c195593cf7405dac3f4fa9ffa5b6 /community/openlibm
parent9906cefe58deb2c3e821a23b474fa051eb7f8c8b (diff)
downloadaports-be26f5cfd9c51d74dece7f0655b793d31381cd0d.tar.bz2
aports-be26f5cfd9c51d74dece7f0655b793d31381cd0d.tar.xz
community/openlibm: upgrade to 0.6.0
No ABI breakages according to https://abi-laboratory.pro/?view=timeline&l=openlibm.
Diffstat (limited to 'community/openlibm')
-rw-r--r--community/openlibm/APKBUILD8
-rw-r--r--community/openlibm/aarch64_fixes.patch65
2 files changed, 2 insertions, 71 deletions
diff --git a/community/openlibm/APKBUILD b/community/openlibm/APKBUILD
index 929ba245cb..a6d881801f 100644
--- a/community/openlibm/APKBUILD
+++ b/community/openlibm/APKBUILD
@@ -1,17 +1,14 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=openlibm
-pkgver=0.5.5
+pkgver=0.6.0
pkgrel=0
pkgdesc="High quality system independent, portable, open source libm implementation"
url="http://www.openlibm.org"
arch="all !s390x"
license="MIT BSD Public-Domain"
-depends=""
-makedepends=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$pkgname/archive/v$pkgver.tar.gz
- aarch64_fixes.patch
powerpc_fixes.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -30,6 +27,5 @@ package() {
make VERSION=$pkgver DESTDIR="$pkgdir" prefix=/usr install
}
-sha512sums="d9e441f177bc7af087c179e9cd1e6bcd98054f19b68e701cf5f6e4518523ed9a69c54ca7c77903031432c13c6e302439c5b74040e9ffa29b52c47978fa5ca662 openlibm-0.5.5.tar.gz
-dd34aef4a1e260305f9e42443b3c1e3fa046c1174346ad449f99deebef3ded6530b03d3b7a210e0acde5a33bb95a0541a0e13cd26c9d82127e05824b811acfc1 aarch64_fixes.patch
+sha512sums="ea7770c5e82ddfe84d7490a5175439cf676f2c517f029a748cfeec174234f33ee04c42ce284753771588a36b4b9b5d8c2f72f2235408d8f9393bdf19abfec7b1 openlibm-0.6.0.tar.gz
76ee57a281275b2bd382f0485e4ca383566af47f3d89981b75ad764c629d82f7f0260fb41cc9eb50f0f175c88b64699aabcc732add321f4d730f38ba7a48238d powerpc_fixes.patch"
diff --git a/community/openlibm/aarch64_fixes.patch b/community/openlibm/aarch64_fixes.patch
deleted file mode 100644
index 4fc7b0fb2a..0000000000
--- a/community/openlibm/aarch64_fixes.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From 238a90959fff053458767dd16f193204869387c0 Mon Sep 17 00:00:00 2001
-From: Yichao Yu <yyc1992@gmail.com>
-Date: Sat, 21 Oct 2017 09:50:50 -0400
-Subject: [PATCH] Fix compilation on AArch64
-
-The 128bit double directory is missing and was never used....
----
- Make.inc | 6 +++++-
- Makefile | 5 +++++
- ld128/Make.files | 14 +++++++++++++-
- 3 files changed, 23 insertions(+), 2 deletions(-)
-
-diff --git a/Make.inc b/Make.inc
-index db84d07..b1d43a7 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -125,8 +125,12 @@ SFLAGS_add += $(SFLAGS_arch)
- LDFLAGS_add += $(LDFLAGS_arch)
-
- CFLAGS_add += -std=c99 -Wall -I$(OPENLIBM_HOME) -I$(OPENLIBM_HOME)/include -I$(OPENLIBM_HOME)/$(ARCH) -I$(OPENLIBM_HOME)/src -DASSEMBLER -D__BSD_VISIBLE -Wno-implicit-function-declaration
--ifneq ($(filter $(ARCH),i387 amd64 aarch64 powerpc),)
-+ifneq ($(filter $(ARCH),i387 amd64 powerpc),)
- CFLAGS_add += -I$(OPENLIBM_HOME)/ld80
-+else
-+ifneq ($(filter $(ARCH),aarch64),)
-+CFLAGS_add += -I$(OPENLIBM_HOME)/ld128
-+endif
- endif
-
-
-diff --git a/Makefile b/Makefile
-index 1834610..e4324a9 100644
---- a/Makefile
-+++ b/Makefile
-@@ -5,6 +5,11 @@ SUBDIRS = src $(ARCH) bsdsrc
- # Add ld80 directory on x86 and x64
- ifneq ($(filter $(ARCH),i387 amd64),)
- SUBDIRS += ld80
-+else
-+ifneq ($(filter $(ARCH),aarch64),)
-+SUBDIRS += ld128
-+else
-+endif
- endif
-
- define INC_template
-diff --git a/ld128/Make.files b/ld128/Make.files
-index 0eab034..1198cfb 100644
---- a/ld128/Make.files
-+++ b/ld128/Make.files
-@@ -1 +1,13 @@
--SRCS = invtrig.c k_cosl.c k_sinl.c k_tanl.c # s_nanl.c s_exp2l.c
-+$(CUR_SRCS) += invtrig.c \
-+ e_acoshl.c e_powl.c k_tanl.c s_exp2l.c \
-+ e_atanhl.c e_lgammal_r.c e_sinhl.c s_asinhl.c s_expm1l.c \
-+ e_coshl.c e_log10l.c e_tgammal.c \
-+ e_expl.c e_log2l.c k_cosl.c s_log1pl.c s_tanhl.c \
-+ e_logl.c k_sinl.c s_erfl.c
-+
-+# s_remquol.c e_fmodl.c s_truncl.c
-+# e_hypotl.c s_floorl.c s_nextafterl.c s_ceill.c s_modfl.c
-+
-+ifneq ($(OS), WINNT)
-+$(CUR_SRCS) += s_nanl.c
-+endif