aboutsummaryrefslogtreecommitdiffstats
path: root/community/opensc/libressl.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-10-19 16:10:53 +0300
committerTimo Teräs <timo.teras@iki.fi>2016-10-19 16:11:10 +0300
commit5589934361999662654f960b2b00260320590d99 (patch)
treef26287415e42a0c2e0f48ba40e5f3bc02ed72adb /community/opensc/libressl.patch
parent72ba34914fface74a63ecc53c358eb9fe0a5c3a6 (diff)
downloadaports-5589934361999662654f960b2b00260320590d99.tar.bz2
aports-5589934361999662654f960b2b00260320590d99.tar.xz
community/opensc: moved from testing
Diffstat (limited to 'community/opensc/libressl.patch')
-rw-r--r--community/opensc/libressl.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/opensc/libressl.patch b/community/opensc/libressl.patch
new file mode 100644
index 0000000000..003328e000
--- /dev/null
+++ b/community/opensc/libressl.patch
@@ -0,0 +1,22 @@
+https://raw.githubusercontent.com/voidlinux/void-packages/4b22d402a290a6192853dd3994e24128023a3b7e/srcpkgs/opensc/patches/libressl.patch
+
+--- a/src/pkcs11/openssl.c.orig 2016-06-05 18:51:11.947157265 +0200
++++ b/src/pkcs11/openssl.c 2016-06-05 18:55:21.067170117 +0200
+@@ -180,7 +180,7 @@
+ e = ENGINE_by_id("gost");
+ if (!e)
+ {
+-#if !defined(OPENSSL_NO_STATIC_ENGINE) && !defined(OPENSSL_NO_GOST)
++#if !defined(LIBRESSL_VERSION_NUMBER) && !defined(OPENSSL_NO_STATIC_ENGINE) && !defined(OPENSSL_NO_GOST)
+ ENGINE_load_gost();
+ e = ENGINE_by_id("gost");
+ #else
+@@ -195,7 +195,7 @@
+ ENGINE_free(e);
+ e = NULL;
+ }
+-#endif /* !OPENSSL_NO_STATIC_ENGINE && !OPENSSL_NO_GOST */
++#endif /* !defined(LIBRESSL_VERSION_NUMBER) && !defined(OPENSSL_NO_STATIC_ENGINE) && !defined(OPENSSL_NO_GOST) */
+ }
+ if (e) {
+ ENGINE_set_default(e, ENGINE_METHOD_ALL);