aboutsummaryrefslogtreecommitdiffstats
path: root/community/ostree
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-06-30 21:36:43 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-06-30 21:38:34 +0200
commit23ee7a986bc66face13eab918bf0497db2b90eed (patch)
treec2cec193810cfb353dfc43cc8770345fcb35d112 /community/ostree
parent6b6eb7d62d3ef9c50dd473dc4f52d8133eb56784 (diff)
downloadaports-23ee7a986bc66face13eab918bf0497db2b90eed.tar.bz2
aports-23ee7a986bc66face13eab918bf0497db2b90eed.tar.xz
community/ostree: add -doc subpackage
Diffstat (limited to 'community/ostree')
-rw-r--r--community/ostree/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/ostree/APKBUILD b/community/ostree/APKBUILD
index f607f07f2c..bc5b7b4aa8 100644
--- a/community/ostree/APKBUILD
+++ b/community/ostree/APKBUILD
@@ -2,23 +2,22 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=ostree
pkgver=2018.6
-pkgrel=0
+pkgrel=1
pkgdesc="Operating system and container binary deployment and upgrades"
url="https://github.com/ostreedev/ostree"
arch="all"
license="LGPL-2.0-or-later"
makedepends="bison glib-dev xz-dev libarchive-dev e2fsprogs-dev
- libsoup-dev gpgme-dev fuse-dev linux-headers"
-subpackages="$pkgname-dev"
+ libsoup-dev gpgme-dev fuse-dev linux-headers gtk-doc libxslt"
+subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/ostreedev/ostree/releases/download/v$pkgver/libostree-$pkgver.tar.xz
- musl-fixes.patch
- "
+ musl-fixes.patch
+ "
options="!check"
builddir="$srcdir/lib$pkgname-$pkgver"
build() {
cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,9 +26,9 @@ build() {
--localstatedir=/var \
--sbindir=/usr/bin \
--libexecdir=/usr/lib \
+ --enable-gtk-doc \
--disable-static \
--disable-glibtest
-
make
}