aboutsummaryrefslogtreecommitdiffstats
path: root/community/pcc-libs
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-09-27 12:01:36 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-09-27 13:17:35 +0200
commitce5853c01e15d67a0ba89e3f795b21443e1ac9c5 (patch)
tree1b2983e1ed9f05d0719fcd2215a74d3d5c21707c /community/pcc-libs
parent547e3100f819d03080c3b45fa0612fbb78e43b4d (diff)
downloadaports-ce5853c01e15d67a0ba89e3f795b21443e1ac9c5.tar.bz2
aports-ce5853c01e15d67a0ba89e3f795b21443e1ac9c5.tar.xz
community/pcc-libs: move from testing
Diffstat (limited to 'community/pcc-libs')
-rw-r--r--community/pcc-libs/APKBUILD49
-rw-r--r--community/pcc-libs/musl-fixes.patch15
2 files changed, 64 insertions, 0 deletions
diff --git a/community/pcc-libs/APKBUILD b/community/pcc-libs/APKBUILD
new file mode 100644
index 0000000000..c2250fba9e
--- /dev/null
+++ b/community/pcc-libs/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=pcc-libs
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="The portable C compiler support libraries."
+url="http://pcc.ludd.ltu.se/"
+arch="x86 x86_64"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="ftp://pcc.ludd.ltu.se/pub/pcc-releases/pcc-libs-$pkgver.tgz
+ musl-fixes.patch"
+
+builddir="$srcdir/"$pkgname-$pkgver
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make -j1 || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="360c157bbf6a7a931c4760ccf4ad704a pcc-libs-1.1.0.tgz
+be1b3746acd6d91ba2f6e2827cbbfd35 musl-fixes.patch"
+sha256sums="dd4cb124da0b2edcda6ceb823c3ca8fc05919d35c89c34dec617517afe6bbfee pcc-libs-1.1.0.tgz
+f17660c6dbd05bc9bce0b373072e60b51411934a717dfd031c55f4458801c48c musl-fixes.patch"
+sha512sums="89d90f246300ab1da652f652c685756aa038017f5b7d57d050bb5c88e01e70b594ffaef8772230fbeb9461e07c5b1df60e85e550ec4717008159218d50c8697a pcc-libs-1.1.0.tgz
+fd8c71cd583c6be29553f2b7e6ce66073afd6d0406ae86f6fbb6a36efe8685be4732d2989180a9b31af734cc9a0973c1c731472f02bad076121f6c3c58391fc4 musl-fixes.patch"
diff --git a/community/pcc-libs/musl-fixes.patch b/community/pcc-libs/musl-fixes.patch
new file mode 100644
index 0000000000..7f41997b1e
--- /dev/null
+++ b/community/pcc-libs/musl-fixes.patch
@@ -0,0 +1,15 @@
+diff -upr pcc-libs-1.1.0.orig/csu/linux/Makefile pcc-libs-1.1.0/csu/linux/Makefile
+--- pcc-libs-1.1.0.orig/csu/linux/Makefile 2016-09-16 19:44:48.113019651 +0200
++++ pcc-libs-1.1.0/csu/linux/Makefile 2016-09-16 19:45:09.666297594 +0200
+@@ -6,9 +6,8 @@ SRCDIR ?= .
+
+ CFLAGS = -I$(SRCDIR)/$(MACH) -I$(SRCDIR) -Wall -Wstrict-prototypes -Wmissing-prototypes
+
+-#OBJS = crt0.o crt1.o gcrt1.o crti.o crtn.o crtbegin.o crtend.o \
+-# crtbeginS.o crtendS.o crtbeginT.o crtendT.o
+-OBJS = crtbegin.o crtend.o crtbeginS.o crtendS.o crtbeginT.o crtendT.o
++OBJS = crt0.o crt1.o gcrt1.o crti.o crtn.o crtbegin.o crtend.o \
++ crtbeginS.o crtendS.o crtbeginT.o crtendT.o
+
+
+ all: $(OBJS)