aboutsummaryrefslogtreecommitdiffstats
path: root/community/pdns
diff options
context:
space:
mode:
authorAndrew Domaszek <brimston3@hg0.us>2017-04-04 18:24:16 -0400
committerJakub Jirutka <jakub@jirutka.cz>2017-04-19 23:42:13 +0200
commit3a679fc9e1d34deefe4f4d2d380b552f368b2a8b (patch)
tree98bb20773949add3c5bd089fba662a21017b2160 /community/pdns
parentd7a3365bf39a2beabe0b5def3d5f359bd0b12951 (diff)
downloadaports-3a679fc9e1d34deefe4f4d2d380b552f368b2a8b.tar.bz2
aports-3a679fc9e1d34deefe4f4d2d380b552f368b2a8b.tar.xz
community/pdns: fix init script, tracking of crashed process
Diffstat (limited to 'community/pdns')
-rw-r--r--community/pdns/APKBUILD4
-rw-r--r--community/pdns/pdns.initd42
2 files changed, 8 insertions, 38 deletions
diff --git a/community/pdns/APKBUILD b/community/pdns/APKBUILD
index 6bfd22d4d9..6b6c599ae6 100644
--- a/community/pdns/APKBUILD
+++ b/community/pdns/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=pdns
pkgver=4.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="PowerDNS Authoritative Server"
url="http://www.powerdns.com/"
arch="all"
@@ -74,5 +74,5 @@ _mv_backend() {
}
sha512sums="58d33ac6cf457a916bae6abd8d2dc17f76fbcd1bd9e649948584dd669f5596b43e3e4d91841700ea1ea2cd1ac102749e503cd9075273540f33a2321e20d8bfc2 pdns-4.0.3.tar.bz2
-71257be925fe57b15ebf29a7810cd70581cb867416ab9562300a1bbc3eb94fcb92ea2eb95f15e3ee3bd409468911077c50f90a2501801b0c8c49ed979f41f3a4 pdns.initd
+5ffe74ef784f30c97f95c6f4d9025ddad150e882b804fb9f24f4cd761f04b7dd934f277a077c5d6f66f1b2cc794bbe71b441ef453d887dda7b0c67605c7d7fba pdns.initd
acde76a5a51232dbd2b1b9fed95328f5bb59e33718338ffaa47618806588a9c3c8691c7e7270944d9e2f40b1fb69fc33e204e2fdfbc9546ab723fc428d2a7955 pdns.conf"
diff --git a/community/pdns/pdns.initd b/community/pdns/pdns.initd
index b6429bf858..88d8b28f26 100644
--- a/community/pdns/pdns.initd
+++ b/community/pdns/pdns.initd
@@ -1,15 +1,7 @@
#!/sbin/openrc-run
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/files/pdns,v 1.10 2007/05/07 20:19:18 swegener Exp $
-name=pdns
-daemon=/usr/sbin/pdns_server
pdns_control=/usr/bin/pdns_control
-extra_started_commands="dump reload"
-extra_commands="monitor"
-
PDNS_INSTANCE="${SVCNAME#pdns[.-]}"
PDNS_CONFIG=""
@@ -20,26 +12,17 @@ else
PDNS_INSTANCE="default"
fi
+command="/usr/sbin/pdns_server"
+command_args="--guardian=no --daemon=no --write-pid=no $PDNS_CONFIG"
+command_background="yes"
+extra_started_commands="dump reload"
+pidfile="/run/$RC_SVCNAME.pid"
+
depend() {
need net
after firewall
}
-start() {
- ebegin "Starting PowerDNS (${PDNS_INSTANCE})"
- ${daemon} \
- ${PDNS_CONFIG} \
- --daemon=yes \
- --guardian=yes
- eend $?
-}
-
-stop() {
- ebegin "Stopping PowerDNS (${PDNS_INSTANCE})"
- ${pdns_control} ${PDNS_CONFIG} quit &>/dev/null
- eend $?
-}
-
reload() {
ebegin "Reloading PowerDNS (${PDNS_INSTANCE})"
${pdns_control} ${PDNS_CONFIG} cycle &>/dev/null
@@ -51,16 +34,3 @@ dump() {
${pdns_control} ${PDNS_CONFIG} list
eend $?
}
-
-monitor() {
- ebegin "Starting PowerDNS (${PDNS_INSTANCE}) in monitor mode"
- ${daemon} \
- ${PDNS_CONFIG} \
- --daemon=no \
- --guardian=no \
- --control-console=yes \
- --loglevel=9 \
- --log-dns-details=yes \
- --query-logging=yes
- eend $?
-}