aboutsummaryrefslogtreecommitdiffstats
path: root/community/pdns
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2017-09-05 14:36:02 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-05 14:41:48 +0000
commit57a51123a91675b55ce9fac8a1a9fe0822e244c8 (patch)
treee26777ca794b1215d56b2b0814cc1e2abee7c2f1 /community/pdns
parente5ef1edd95d2d6edb233050ec45919ba753ef71d (diff)
downloadaports-57a51123a91675b55ce9fac8a1a9fe0822e244c8.tar.bz2
aports-57a51123a91675b55ce9fac8a1a9fe0822e244c8.tar.xz
community/pdns: add geoip backend
Diffstat (limited to 'community/pdns')
-rw-r--r--community/pdns/APKBUILD18
-rw-r--r--community/pdns/pdns.conf15
-rw-r--r--community/pdns/pdns.initd1
3 files changed, 27 insertions, 7 deletions
diff --git a/community/pdns/APKBUILD b/community/pdns/APKBUILD
index e95cb63027..dc7a71cb87 100644
--- a/community/pdns/APKBUILD
+++ b/community/pdns/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Contributor: Matt Smith <mcs@darkregion.net>
# Contributor: Olivier Mauras <olivier@mauras.ch>
+# Contributor: Daniel Isaksen <d@duniel.no>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=pdns
pkgver=4.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="PowerDNS Authoritative Server"
url="http://www.powerdns.com/"
arch="all"
-license="GPL"
+license="GPL-2.0"
depends=""
depends_dev=""
makedepends="$depends_dev boost-dev lua-dev openldap-dev mariadb-dev
- postgresql-dev sqlite-dev"
+ postgresql-dev sqlite-dev geoip-dev yaml-cpp-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-doc
$pkgname-backend-bind:backend_bind
@@ -20,7 +21,8 @@ subpackages="$pkgname-doc
$pkgname-backend-mysql:backend_mysql
$pkgname-backend-pgsql:backend_pgsql
$pkgname-backend-pipe:backend_pipe
- $pkgname-backend-sqlite3:backend_sqlite3"
+ $pkgname-backend-sqlite3:backend_sqlite3
+ $pkgname-backend-geoip:backend_geoip"
pkgusers="pdns"
pkggroups="pdns"
source="http://downloads.powerdns.com/releases/pdns-$pkgver.tar.bz2
@@ -30,6 +32,7 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+
./configure --prefix=/usr \
--sysconfdir=/etc/$pkgname \
--mandir=/usr/share/man \
@@ -37,7 +40,7 @@ build() {
--localstatedir=/var \
--libdir=/usr/lib/pdns \
--with-modules="" \
- --with-dynmodules="bind ldap gmysql gpgsql pipe gsqlite3" \
+ --with-dynmodules="bind ldap gmysql gpgsql pipe gsqlite3 geoip" \
--disable-static
make
}
@@ -61,6 +64,7 @@ backend_mysql() { _mv_backend gmysql; }
backend_pgsql() { _mv_backend gpgsql; }
backend_pipe() { _mv_backend pipe; }
backend_sqlite3() { _mv_backend gsqlite3 sqlite; }
+backend_geoip() { _mv_backend geoip geoip; }
_mv_backend() {
local backend=$1
@@ -73,5 +77,5 @@ _mv_backend() {
}
sha512sums="4ef4705cd990b03976775167c7c37850d45907e198549feda5f5701172e008e3f1f74a35a9bebdb24b63dec15ff63cb2cc9dfc8f92e4e1012e0539c5a88b845b pdns-4.0.4.tar.bz2
-4e729120af0f5e6ce8f13fdb97af2e8471300df3c1e2e250f855861214a0bf733b5dc77f0e414f2969d81c13423cf29d0bfb7cb4938075ef763fd14877a54a79 pdns.initd
-acde76a5a51232dbd2b1b9fed95328f5bb59e33718338ffaa47618806588a9c3c8691c7e7270944d9e2f40b1fb69fc33e204e2fdfbc9546ab723fc428d2a7955 pdns.conf"
+3f5b202c56408168ddbf81b47f5c48ca65de91ada88751213a06a1096334b89176c5a6a58f3c6a893a2d15b51ece9f2a64d7d2ea836220a3e45fe362969c6cfa pdns.initd
+c8f8d152c4d29660aa56a9dbfd0d268474f9bd26993ad9e7d8ef54725d02a02e27c1a11adc67bf40f5dd871a677648d45fa76222a063907e0dfb2420111d5dc8 pdns.conf"
diff --git a/community/pdns/pdns.conf b/community/pdns/pdns.conf
index 67a9f3fe66..1705e14893 100644
--- a/community/pdns/pdns.conf
+++ b/community/pdns/pdns.conf
@@ -334,4 +334,19 @@ webserver=no
#
wildcards=yes
+#################################
+# geoip-database-files Comma, tab or space separated list of files to open
+#
+
+#################################
+# geoip-database-cache Specifies the kind of caching that is done on the database
+#
+
+#################################
+# geoip-zones-file Specifies the full path of the zone configuration file to use
+#
+
+#################################
+# geoip-dnssec-keydir Specifies the full path of a directory that will contain DNSSEC keys
+#
diff --git a/community/pdns/pdns.initd b/community/pdns/pdns.initd
index 4d36eb873a..ee354aa437 100644
--- a/community/pdns/pdns.initd
+++ b/community/pdns/pdns.initd
@@ -35,3 +35,4 @@ dump() {
"$pdns_control" $pdns_config list
eend $?
}
+