aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-autovivification
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-27 13:20:49 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-27 13:20:51 +0000
commit562bc57b582f8d4a3c659cd124fa939cf9d7deb7 (patch)
tree58bb714c50c6a3e4bdd2527ab0f40d675dccf067 /community/perl-autovivification
parentae852e430b290c505942dde52442793ff69171fa (diff)
downloadaports-562bc57b582f8d4a3c659cd124fa939cf9d7deb7.tar.bz2
aports-562bc57b582f8d4a3c659cd124fa939cf9d7deb7.tar.xz
community/perl-[a-b]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-autovivification')
-rw-r--r--community/perl-autovivification/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/perl-autovivification/APKBUILD b/community/perl-autovivification/APKBUILD
index 3878084bda..ff36e88a45 100644
--- a/community/perl-autovivification/APKBUILD
+++ b/community/perl-autovivification/APKBUILD
@@ -4,21 +4,22 @@
pkgname=perl-autovivification
_pkgreal=autovivification
pkgver=0.18
-pkgrel=0
+pkgrel=1
pkgdesc="Lexically disable autovivification."
url="http://search.cpan.org/dist/autovivification/"
arch="all"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/V/VP/VPIT/$_pkgreal-$pkgver.tar.gz"
+
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,12 +29,17 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}