aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-class-load-xs
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-12 12:44:36 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-12 12:47:11 +0000
commit442fbd8bc0d3b26b3e6d54684c800c6d1b1eab0a (patch)
tree3ca229f9cef6c06f56c121611aac01b4b8e4d9cb /community/perl-class-load-xs
parent280cb52f4ca05272185ea6f57cd74a6ef4aaff92 (diff)
downloadaports-442fbd8bc0d3b26b3e6d54684c800c6d1b1eab0a.tar.bz2
aports-442fbd8bc0d3b26b3e6d54684c800c6d1b1eab0a.tar.xz
community/perl-class-load-xs: upgrade to 0.10, modernize APKBUILD
Diffstat (limited to 'community/perl-class-load-xs')
-rw-r--r--community/perl-class-load-xs/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/perl-class-load-xs/APKBUILD b/community/perl-class-load-xs/APKBUILD
index 64b9d69751..8599516219 100644
--- a/community/perl-class-load-xs/APKBUILD
+++ b/community/perl-class-load-xs/APKBUILD
@@ -3,39 +3,41 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-class-load-xs
_pkgreal=Class-Load-XS
-pkgver=0.09
-pkgrel=1
+pkgver=0.10
+pkgrel=0
pkgdesc="XS implementation of parts of Class::Load"
url="http://search.cpan.org/dist/Class-Load-XS/"
arch="all"
license="Artistic-2"
cpandepends="perl-class-load"
-cpanmakedepends=" perl-test-requires perl-test-fatal perl-module-implementation "
+cpanmakedepends="perl-test-requires perl-test-fatal perl-module-implementation perl-test-needs"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="98eb8daf7f23c872fc7f503a7e34f598 Class-Load-XS-0.09.tar.gz"
-sha256sums="bbec3b916df9e48827950a297bf53ef4dd59ed6376142099504307a42b553baa Class-Load-XS-0.09.tar.gz"
-sha512sums="9b24637cf7b035ba369f05e42c0bd5a8590e001f2395b46df078635a50bb3df58ad57850be0010d092ae2530d9a545bbcc5f0055f6ae7f166c93905c022d469d Class-Load-XS-0.09.tar.gz"
+sha512sums="16ab845dc393567f0b0e9597eda7d7678b8a41d218823a166bacdfd4dc93e704a6aff98662340b8d7f4d045a60530071bb84ea8da8be5a6930af47722207d126 Class-Load-XS-0.10.tar.gz"