aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-class-load
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 09:07:17 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:36 +0000
commitdf55cc76676a3f72c1a55e382efd48d7f9a99da5 (patch)
tree4a919152081509cdacf65b8f9c821f8033c36ae0 /community/perl-class-load
parentc0280255116150f995bf22eb5c641e0e383440b7 (diff)
downloadaports-df55cc76676a3f72c1a55e382efd48d7f9a99da5.tar.bz2
aports-df55cc76676a3f72c1a55e382efd48d7f9a99da5.tar.xz
community/perl-class-load: moved from testing
Diffstat (limited to 'community/perl-class-load')
-rw-r--r--community/perl-class-load/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/perl-class-load/APKBUILD b/community/perl-class-load/APKBUILD
new file mode 100644
index 0000000000..9442de4c41
--- /dev/null
+++ b/community/perl-class-load/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-class-load
+_pkgreal=Class-Load
+pkgver=0.23
+pkgrel=0
+pkgdesc="a working (require "Class::Name") and more"
+url="http://search.cpan.org/dist/Class-Load/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-module-runtime perl-module-implementation perl-package-stash perl-data-optlist perl-try-tiny"
+cpanmakedepends="perl-test-requires perl-test-fatal perl-test-without-module"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="080973026b82051117b6c18f5d77aaa9 Class-Load-0.23.tar.gz"
+sha256sums="f2bca579e72ea96c6b1c5ebc86dfa1929062c412443277f0bc0437e50874b28f Class-Load-0.23.tar.gz"
+sha512sums="c4e39a0b53dcb9e91c6ac160b15d253aa257fc327c2f4e333b8a3689a6c697412385d47d0a52e55a9420b8cc1a7f46d8d0c1ff54f13ae2a88e0f9df8935cffed Class-Load-0.23.tar.gz"