aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-datetime-format-strptime
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-24 11:25:39 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-24 11:26:40 +0000
commit5bd7095f8a777176273e1ef65e9d89287139f356 (patch)
tree4817bd546bdb4fd966a0e3d190c634b3f21f03cc /community/perl-datetime-format-strptime
parent288b1942404852a07d4e0c54b4a6e9a16e50f310 (diff)
downloadaports-5bd7095f8a777176273e1ef65e9d89287139f356.tar.bz2
aports-5bd7095f8a777176273e1ef65e9d89287139f356.tar.xz
community/perl-datetime-format-strptime: upgrade to 1.74 and modernize
Diffstat (limited to 'community/perl-datetime-format-strptime')
-rw-r--r--community/perl-datetime-format-strptime/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/perl-datetime-format-strptime/APKBUILD b/community/perl-datetime-format-strptime/APKBUILD
index 7c2dfa04ca..441234194a 100644
--- a/community/perl-datetime-format-strptime/APKBUILD
+++ b/community/perl-datetime-format-strptime/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-datetime-format-strptime
_pkgreal=DateTime-Format-Strptime
-pkgver=1.73
+pkgver=1.74
pkgrel=0
pkgdesc="Parse and format strp and strf time patterns"
url="http://search.cpan.org/dist/DateTime-Format-Strptime/"
@@ -12,30 +12,35 @@ license="Artistic-2"
cpandepends="perl-params-validate perl-datetime perl-try-tiny
perl-package-deprecationmanager perl-datetime-timezone
perl-datetime-locale"
-cpanmakedepends=" perl-test-warnings perl-test-fatal "
+cpanmakedepends="perl-test-warnings perl-test-fatal "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="c259473e1120a9e40020cba2c7d008227521dbca0d2906878ee75e1ebc58e82760386bb32ebb1e987e68dfa4ce7f1e532dc4bfdf70467383425705e3f1c18d15 DateTime-Format-Strptime-1.73.tar.gz"
+sha512sums="3b2b640f93956e82aff47f068c596018700615414c9b9ccf8d6bf68ad7b626ec86a831ec2b68807d7f137c10d4b8cfa5d2d50a6304252f3dfecbe9ff94e59617 DateTime-Format-Strptime-1.74.tar.gz"