aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-digest-bubblebabble
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-04 19:12:53 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-04 19:12:53 +0000
commitf7805e8850a0183df538cba1edbd696567dd81ca (patch)
tree91f88b8d46baecd4cc75f04c0ad687f8f1615206 /community/perl-digest-bubblebabble
parent41d5e722c8c8e64fa2a5920e40e08c184b3da63d (diff)
downloadaports-f7805e8850a0183df538cba1edbd696567dd81ca.tar.bz2
aports-f7805e8850a0183df538cba1edbd696567dd81ca.tar.xz
community/perl-digest-bubblebabble: modernize APKBUILD
Diffstat (limited to 'community/perl-digest-bubblebabble')
-rw-r--r--community/perl-digest-bubblebabble/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/perl-digest-bubblebabble/APKBUILD b/community/perl-digest-bubblebabble/APKBUILD
index a2b0a69efc..4d13e38940 100644
--- a/community/perl-digest-bubblebabble/APKBUILD
+++ b/community/perl-digest-bubblebabble/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-digest-bubblebabble
_pkgreal=Digest-BubbleBabble
pkgver=0.02
-pkgrel=1
+pkgrel=2
pkgdesc="Create bubble-babble fingerprints"
url="http://search.cpan.org/dist/Digest-BubbleBabble/"
arch="noarch"
@@ -16,20 +16,25 @@ makedepends="perl-dev $cpanmakedepends perl-module-install"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}