aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-io-tee
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-08-20 12:03:21 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-22 23:40:30 +0200
commit4ad2b82edf1723c0e898ca9d85cefe4d7001143c (patch)
tree4045bc0411605e55e1c7b5f672b8cb62262b1238 /community/perl-io-tee
parent2ba44dd8402e146b9d1a39aaddd2dbda838c0fc5 (diff)
downloadaports-4ad2b82edf1723c0e898ca9d85cefe4d7001143c.tar.bz2
aports-4ad2b82edf1723c0e898ca9d85cefe4d7001143c.tar.xz
community/perl-io-tee: upgrade to 0.65
Diffstat (limited to 'community/perl-io-tee')
-rw-r--r--community/perl-io-tee/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/perl-io-tee/APKBUILD b/community/perl-io-tee/APKBUILD
index 29198bab43..9c0ba2f1c6 100644
--- a/community/perl-io-tee/APKBUILD
+++ b/community/perl-io-tee/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=perl-io-tee
-pkgver=0.64
+pkgver=0.65
_realname=IO-Tee-$pkgver
pkgrel=0
pkgdesc="Multiplex output to multiple output handles"
@@ -13,22 +13,24 @@ cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/K/KE/KENSHAN/$_realname.tar.gz"
-
-_builddir="$srcdir"/$_realname
+source="$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/N/NE/NEILB/$_realname.tar.gz"
+builddir="$srcdir"/$_realname
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="97d91e38fcadc1f01d8030a8d4f30701 IO-Tee-0.64.tar.gz"
-sha256sums="3ed276b1c2d3511338653c2532e73753d284943c1a8f5159ff37fecc2b345ed6 IO-Tee-0.64.tar.gz"
-sha512sums="9473a9ce3222ee6998cc53851a34051a9ae5990b9c514b5e5d322832d76f0e20d7af51bf7f06603ad927ab9789e5ab10da7a0693e4867112cd3e1dc1ca25d017 IO-Tee-0.64.tar.gz"
+sha512sums="f0f2f069c9c43098fc8fb343ef3a701e8ea5d6171a7f86b3c296f542435b1305f263085ede07431cfe34ccf02d845c8f3719ddf1eb6fe0d8def0c730f8e97236 perl-io-tee-0.65.tar.gz"