aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-module-scandeps/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-09-18 18:24:29 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-09-18 18:24:29 +0200
commit100fbef33efcaf58ed6abddf669d5a56f8a885be (patch)
treeaabcaf21e82dba49de5bde7d1938f13978c22870 /community/perl-module-scandeps/APKBUILD
parentd3b27f881c6aed7cb9db871afaa6c41324faacb2 (diff)
downloadaports-100fbef33efcaf58ed6abddf669d5a56f8a885be.tar.bz2
aports-100fbef33efcaf58ed6abddf669d5a56f8a885be.tar.xz
community/perl-module-scandeps: improve abuild
Diffstat (limited to 'community/perl-module-scandeps/APKBUILD')
-rw-r--r--community/perl-module-scandeps/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/perl-module-scandeps/APKBUILD b/community/perl-module-scandeps/APKBUILD
index 3951f93aab..cdd21488d9 100644
--- a/community/perl-module-scandeps/APKBUILD
+++ b/community/perl-module-scandeps/APKBUILD
@@ -17,18 +17,21 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare || return 1
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make && make test
}
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}