aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-perlio-utf8_strict
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-14 00:41:33 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-16 18:07:30 +0000
commitaec19a59ca415ed07e6b50017dfd631126dce004 (patch)
tree24e1ee789c77f905280805c6c02e61ab712f5848 /community/perl-perlio-utf8_strict
parentad8c20025ea59225bab3a2ef55dd8cbb954cf7ce (diff)
downloadaports-aec19a59ca415ed07e6b50017dfd631126dce004.tar.bz2
aports-aec19a59ca415ed07e6b50017dfd631126dce004.tar.xz
community/perl-perlio-utf8_strict: new aport. In community since is a dependency of biber 2.8
Diffstat (limited to 'community/perl-perlio-utf8_strict')
-rw-r--r--community/perl-perlio-utf8_strict/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/perl-perlio-utf8_strict/APKBUILD b/community/perl-perlio-utf8_strict/APKBUILD
new file mode 100644
index 0000000000..1781c37815
--- /dev/null
+++ b/community/perl-perlio-utf8_strict/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-perlio-utf8_strict
+_pkgreal=PerlIO-utf8_strict
+pkgver=0.007
+pkgrel=0
+pkgdesc="Fast and correct UTF-8 IO"
+url="http://search.cpan.org/dist/PerlIO-utf8_strict/"
+arch="all"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+cpancheckdepends="perl-test-exception"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="0d39be9bcbab4cea087f59c67dc1af6773b6258c5e836590ff58cc18bf3392ba6e95c55a0c7ce94236e0be7053802b4b1d6010130355e1a973a3698aaf49af0f PerlIO-utf8_strict-0.007.tar.gz"