aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-rt-extension-commandbymail
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-17 15:34:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-17 15:34:53 +0000
commit11804dcf1721521b45870912445f1ba3be66a62f (patch)
tree27dd1580d7a59c0eac2782f02432f50f96c7ebfd /community/perl-rt-extension-commandbymail
parent40dba0a540a0f0160e2a1db77c2c238e974c897a (diff)
downloadaports-11804dcf1721521b45870912445f1ba3be66a62f.tar.bz2
aports-11804dcf1721521b45870912445f1ba3be66a62f.tar.xz
community/perl-rt-extension-commandbymail: upgrade to 3.00
Diffstat (limited to 'community/perl-rt-extension-commandbymail')
-rw-r--r--community/perl-rt-extension-commandbymail/APKBUILD27
-rw-r--r--community/perl-rt-extension-commandbymail/fix-build.patch9
2 files changed, 21 insertions, 15 deletions
diff --git a/community/perl-rt-extension-commandbymail/APKBUILD b/community/perl-rt-extension-commandbymail/APKBUILD
index 29eda76646..f5d63c81c0 100644
--- a/community/perl-rt-extension-commandbymail/APKBUILD
+++ b/community/perl-rt-extension-commandbymail/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-rt-extension-commandbymail
_pkgreal=RT-Extension-CommandByMail
-pkgver=0.17
+pkgver=3.00
pkgrel=0
pkgdesc="RT4 extension to change metadata of a ticket via email"
url="http://search.cpan.org/dist/RT-Extension-CommandByMail/"
@@ -15,30 +15,27 @@ cpanmakedepends=" "
depends="$cpandepends"
makedepends="rt4 perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/F/FA/FALCONE/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/B/BP/BPS/RT-Extension-CommandByMail-$pkgver.tar.gz
+ fix-build.patch"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+# Running tests would require RT4 database to be available
+options="!check"
-prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- # Running tests would require RT4 database to be available
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
package() {
- cd "$_builddir"
- make PERL_INSTALL_ROOT="$pkgdir" pure_install || return 1
+ cd "$builddir"
+ make PERL_INSTALL_ROOT="$pkgdir" pure_install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist -o -name Test.pm \) -delete
find "$pkgdir" -type d -delete 2> /dev/null
}
-md5sums="bcf4a81c4e3a81e6c93f72803d41f2ba RT-Extension-CommandByMail-0.17.tar.gz"
-sha256sums="f1e04965e6d40e88730e2e3db3e06512a5c29a695b557140c9431ba3e6a1fa43 RT-Extension-CommandByMail-0.17.tar.gz"
-sha512sums="6bc13dfd7e90a2d8163922274fdb5d6be9df01bc27c46b2c191a8e62d169a0e1a8f41a79d84aa580bc695ece345eb1686eeb85d0aea13de46cd1ed31e904b506 RT-Extension-CommandByMail-0.17.tar.gz"
+sha512sums="91ea0bd9f9aa32ee09635a910c5d082032bcd94170e22854833c1aa6aacdc68d54687d32cbc92b5e298e62812d23d2fe81e30acd55d11d6d2e910e210be8930c RT-Extension-CommandByMail-3.00.tar.gz
+75fd4f293da4beff01b7cc6511d040b350791e425736104cc9d382e6f172acf66cdbbbf5c02d500e70b3df773ad02af25a78a66c21c70079a7bc5ecc11e1812c fix-build.patch"
diff --git a/community/perl-rt-extension-commandbymail/fix-build.patch b/community/perl-rt-extension-commandbymail/fix-build.patch
new file mode 100644
index 0000000000..dedb7e40b6
--- /dev/null
+++ b/community/perl-rt-extension-commandbymail/fix-build.patch
@@ -0,0 +1,9 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 6e3ef4a..e13a94f 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++BEGIN { push @INC, '.'; }
+ use inc::Module::Install;
+
+ RTx ('RT-Extension-CommandByMail');