aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-sub-install
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 13:07:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 13:31:30 +0000
commit3ce302210e5b0a911d9657215d691b8fe4e5b9b5 (patch)
tree778ae8d17fb65f669c60b8d5eeeb3aa43bb87d58 /community/perl-sub-install
parenta439676586c0e22b38559c0cfb70d81123930b3a (diff)
downloadaports-3ce302210e5b0a911d9657215d691b8fe4e5b9b5.tar.bz2
aports-3ce302210e5b0a911d9657215d691b8fe4e5b9b5.tar.xz
community/perl-[n-s]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-sub-install')
-rw-r--r--community/perl-sub-install/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/perl-sub-install/APKBUILD b/community/perl-sub-install/APKBUILD
index 47171b686c..25e4daed09 100644
--- a/community/perl-sub-install/APKBUILD
+++ b/community/perl-sub-install/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-sub-install
_pkgreal=Sub-Install
pkgver=0.928
-pkgrel=0
+pkgrel=1
pkgdesc="install subroutines into packages easily"
url="http://search.cpan.org/dist/Sub-Install/"
arch="noarch"
@@ -16,26 +16,29 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="e1ce4f9cb6b2f6b8778b036c31afa5ab Sub-Install-0.928.tar.gz"
-sha256sums="61e567a7679588887b7b86d427bc476ea6d77fffe7e0d17d640f89007d98ef0f Sub-Install-0.928.tar.gz"
sha512sums="3f25df9f5992075968830d4235e9f6520c526331b9180391e41483241d43253a61ad8dc381d77aaeb6c6fb841cfc5c097598e62abb46208894275c393a133ade Sub-Install-0.928.tar.gz"