aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-most
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-test-most
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-test-most')
-rw-r--r--community/perl-test-most/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/perl-test-most/APKBUILD b/community/perl-test-most/APKBUILD
index 996864d6c9..a94a3329fa 100644
--- a/community/perl-test-most/APKBUILD
+++ b/community/perl-test-most/APKBUILD
@@ -3,7 +3,7 @@
pkgname=perl-test-most
_pkgreal=Test-Most
pkgver=0.35
-pkgrel=0
+pkgrel=1
pkgdesc="unknown"
url="http://search.cpan.org/dist/Test-Most/"
arch="noarch"
@@ -15,26 +15,29 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/O/OV/OVID/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="03dbabd34d6f40af8bd47f5fbb0c6989 Test-Most-0.35.tar.gz"
-sha256sums="9897a6f4d751598d2ed1047e01c1554b01d0f8c96c45e7e845229782bf6f657f Test-Most-0.35.tar.gz"
sha512sums="1b2d201811e59d7afce47ff5f7da67c170d4685ffbec23360757b5cacc9fe72fc82609bc46cc9d8e351fdb75715696457c201dd94fadaeca70a6f31690236291 Test-Most-0.35.tar.gz"