aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-text-quoted
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-11-01 14:24:47 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-11-01 14:24:47 +0000
commit40bd021c05f62c4dd95c3e9c4c050d7a1799a013 (patch)
tree7631e1d42419f00c09fed05bd886493e8952fdc4 /community/perl-text-quoted
parenta35da95137f108115d9ffcb62676e6bf2fc7aa64 (diff)
downloadaports-40bd021c05f62c4dd95c3e9c4c050d7a1799a013.tar.bz2
aports-40bd021c05f62c4dd95c3e9c4c050d7a1799a013.tar.xz
community/perl-text-quoted: move to community
Diffstat (limited to 'community/perl-text-quoted')
-rw-r--r--community/perl-text-quoted/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-text-quoted/APKBUILD b/community/perl-text-quoted/APKBUILD
new file mode 100644
index 0000000000..9a1987e1b0
--- /dev/null
+++ b/community/perl-text-quoted/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-text-quoted
+pkgver=2.08
+pkgrel=2
+pkgdesc="Text::Quoted perl module"
+url="http://search.cpan.org/dist/Text-Quoted/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl perl-text-autoformat"
+makedepends="perl-dev perl-module-install"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/Text-Quoted-$pkgver.tar.gz"
+
+builddir="$srcdir/Text-Quoted-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="bbe48bf580e6628008728cbff5d6eba8f47664bde71920ff3cb55e45992cb8500730c5228726451e2bee1b6028fd56401e51e80ea73cd9b1f1386211dfce6fde Text-Quoted-2.08.tar.gz"