aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-unicode-collate
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-15 15:37:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-15 20:07:18 +0000
commit0c8f731d6e4a414e5b2a75427d84df07ee70f20e (patch)
treedb158b910175d314719066a90099dbd6b1d83ef1 /community/perl-unicode-collate
parent8cf6c4f07bd0e25adf1be1d5ce696b4031ef9392 (diff)
downloadaports-0c8f731d6e4a414e5b2a75427d84df07ee70f20e.tar.bz2
aports-0c8f731d6e4a414e5b2a75427d84df07ee70f20e.tar.xz
community/perl-unicode-collate: rebuild against perl 5.26
Diffstat (limited to 'community/perl-unicode-collate')
-rw-r--r--community/perl-unicode-collate/APKBUILD21
-rw-r--r--community/perl-unicode-collate/Unicode-Collate-1.19-Fixes-for-removal-dot-from-INC.patch24
2 files changed, 34 insertions, 11 deletions
diff --git a/community/perl-unicode-collate/APKBUILD b/community/perl-unicode-collate/APKBUILD
index 03378b477c..a377ca0ad3 100644
--- a/community/perl-unicode-collate/APKBUILD
+++ b/community/perl-unicode-collate/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-unicode-collate
_pkgreal=Unicode-Collate
pkgver=1.19
-pkgrel=1
+pkgrel=2
pkgdesc="Unicode Collation Algorithm"
url="http://search.cpan.org/dist/Unicode-Collate/"
arch="all"
@@ -14,21 +14,21 @@ cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/S/SA/SADAHIRO/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/S/SA/SADAHIRO/$_pkgreal-$pkgver.tar.gz
+ Unicode-Collate-1.19-Fixes-for-removal-dot-from-INC.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare || return 1
-
+build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make && make test
}
-build() {
+check() {
cd "$builddir"
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make test
}
package() {
@@ -42,6 +42,5 @@ doc() {
replaces="perl-doc"
}
-md5sums="6f9dcc7801fa2516993dcb59f8b61f6d Unicode-Collate-1.19.tar.gz"
-sha256sums="c3ff558c28d4fecb6fb77fbc1936518536e115c3b1eed9b990755e00bb479570 Unicode-Collate-1.19.tar.gz"
-sha512sums="580bca6e96dd474b223ec9f971d6b8a4fc96d1bbffdc278dfa679d511455940e088f19069647715c2ae7c8e52972a59107cbc6d1bf3537de1c314feab2f4c21b Unicode-Collate-1.19.tar.gz"
+sha512sums="580bca6e96dd474b223ec9f971d6b8a4fc96d1bbffdc278dfa679d511455940e088f19069647715c2ae7c8e52972a59107cbc6d1bf3537de1c314feab2f4c21b Unicode-Collate-1.19.tar.gz
+c80607164c7c6ff180770e4e296e645f04e7cda2868039a012c6fb51fdd6951703181165d1c71a7407f938df9ccff59c5ce63784e30b1a3ae8907d0b4b8dd1f3 Unicode-Collate-1.19-Fixes-for-removal-dot-from-INC.patch"
diff --git a/community/perl-unicode-collate/Unicode-Collate-1.19-Fixes-for-removal-dot-from-INC.patch b/community/perl-unicode-collate/Unicode-Collate-1.19-Fixes-for-removal-dot-from-INC.patch
new file mode 100644
index 0000000000..aae5e3bb6e
--- /dev/null
+++ b/community/perl-unicode-collate/Unicode-Collate-1.19-Fixes-for-removal-dot-from-INC.patch
@@ -0,0 +1,24 @@
+diff -up Unicode-Collate-1.19/mklocale.orig Unicode-Collate-1.19/mklocale
+--- Unicode-Collate-1.19/mklocale.orig 2017-05-11 14:46:13.491501304 +0200
++++ Unicode-Collate-1.19/mklocale 2017-05-11 14:48:21.829764058 +0200
+@@ -546,7 +546,7 @@ for my $txt (@txts) {
+ s/\s*\z/.pm/;
+ my $f = File::Spec->catfile($CUR_DIR, split /::/, $_);
+ $f = 'Korean.pm' if /::Korean\.pm/; # using the newer one
+- require $f;
++ require "./$f";
+ next;
+ }
+ if (/^(alternate)\s+(\S+)/) {
+diff -up Unicode-Collate-1.19/Makefile.PL.orig Unicode-Collate-1.19/Makefile.PL
+--- Unicode-Collate-1.19/Makefile.PL.orig 2017-05-11 14:57:57.113506081 +0200
++++ Unicode-Collate-1.19/Makefile.PL 2017-05-11 14:57:25.895682439 +0200
+@@ -6,7 +6,7 @@ my $clean = {};
+ if (-f "Collate.xs") {
+ print "Making header files for XS...\n";
+
+- do 'mkheader' or die $@ || "mkheader: $!";
++ do './mkheader' or die $@ || "mkheader: $!";
+
+ $clean = { FILES => 'ucatbl.h' };
+ }