aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-unicode-string
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-unicode-string
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-unicode-string')
-rw-r--r--community/perl-unicode-string/APKBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/community/perl-unicode-string/APKBUILD b/community/perl-unicode-string/APKBUILD
index 2c7fb96ff5..aa5e88f30b 100644
--- a/community/perl-unicode-string/APKBUILD
+++ b/community/perl-unicode-string/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-unicode-string
_pkgreal=Unicode-String
pkgver=2.09
-pkgrel=5
+pkgrel=6
pkgdesc="String of Unicode characters for perl (UCS2/UTF16)"
url="http://search.cpan.org/dist/Unicode-String/"
arch="all"
@@ -18,34 +18,32 @@ source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_pkgreal-$pkgver.tar.g
perl-Unicode-String-2.09-undefined.patch
"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="553e68e603723bf7c631f8701ab0d678 Unicode-String-2.09.tar.gz
-b08a47f2bd8b046a98fe4951f3eb6e43 perl-Unicode-String-2.09-undefined.patch"
-sha256sums="c817bedb954ea2d488bade56059028b99e0198f6826482e2f68fd6d78653faad Unicode-String-2.09.tar.gz
-7128483d06c846a9fbfbc1dc501b755b879914885f12559fec30ac4f6fb12d39 perl-Unicode-String-2.09-undefined.patch"
sha512sums="88bd5fe4a1e8ac05b7da5f75411f3e2cb17fb756ca926ace7f46d047ba7a7f22e54462efb61c2f0bf651d2c63d6fe74bffa8b7bcf49aa59847135a43b5cde759 Unicode-String-2.09.tar.gz
b25a6c91d5ecc11dd3c8a675024111a3dfadaf3b22f2b3000f5fb3f7e79741b28aafa709b3c72ff7e6f4f936d8fbc38f50ca5994513b47badb57a31872e99450 perl-Unicode-String-2.09-undefined.patch"