aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-yaml/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 08:54:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:36 +0000
commit0087518ca1d7b17ecb0f9df40684704d1c450190 (patch)
tree37609848b331cdcbbef8da59b60dcb2eb533f8e1 /community/perl-yaml/APKBUILD
parent38c141320e0f0a13ad2ce9ce8217e7cb453c01d2 (diff)
downloadaports-0087518ca1d7b17ecb0f9df40684704d1c450190.tar.bz2
aports-0087518ca1d7b17ecb0f9df40684704d1c450190.tar.xz
community/perl-yaml: moved from testing
Diffstat (limited to 'community/perl-yaml/APKBUILD')
-rw-r--r--community/perl-yaml/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/perl-yaml/APKBUILD b/community/perl-yaml/APKBUILD
new file mode 100644
index 0000000000..68800002dd
--- /dev/null
+++ b/community/perl-yaml/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-yaml
+_pkgreal=YAML
+pkgver=1.18
+pkgrel=0
+pkgdesc="YAML Ain't Markup Language (tm)"
+url="http://search.cpan.org/dist/YAML/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-test-yaml"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TI/TINITA/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="79b6cc821fe157790a6448d1f791f6de YAML-1.18.tar.gz"
+sha256sums="c8c4ebf538b5c9b4f53bf3c80a436229b2f28ecd4dbde54e22b470791d04fd39 YAML-1.18.tar.gz"
+sha512sums="6656ed5a9906e3b7888c3a014e8ab459adb8eee471a31b6c1209ff79c72f7ffda7fadb729ac334bf338ba264068f060a83ca31664f3c1d720fc8195231e459f4 YAML-1.18.tar.gz"