aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5-mailparse/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-28 13:54:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-28 18:38:20 +0200
commit4272e802a1be191657becb739e6a248c1d0411a7 (patch)
treea07a25b7c99d7da326957a88173ba49583cf6b2a /community/php5-mailparse/APKBUILD
parent3e272105092cd9804a5a022a188db929ebf440da (diff)
downloadaports-4272e802a1be191657becb739e6a248c1d0411a7.tar.bz2
aports-4272e802a1be191657becb739e6a248c1d0411a7.tar.xz
community/*: move php5 and dependent pkgs from main
There two main reasons for this change: * Active support of PHP 5.x ended on January 2017, security support will end on December 2018. Packages in the main repository should be supported for at least 2 years, this means until first quarter of 2019 for the upcoming v3.6. * php7 and its extensions are currently in the community repository, so we can't use single abuild for both php5-* and php7-* packages (as we do for Python and Lua packages). This change was suggested by @vakartel, approved by @ncopa, @kaniini, and @jirutka.
Diffstat (limited to 'community/php5-mailparse/APKBUILD')
-rw-r--r--community/php5-mailparse/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/php5-mailparse/APKBUILD b/community/php5-mailparse/APKBUILD
new file mode 100644
index 0000000000..b2e3483d8f
--- /dev/null
+++ b/community/php5-mailparse/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_php=php5
+pkgname=${_php}-mailparse
+_pkgreal=mailparse
+pkgver=2.1.6
+_pkgver=${pkgver/_rc/RC}
+pkgrel=2
+pkgdesc="PHP extension for email message manipulation"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="${_php}-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+_builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php/conf.d/$_pkgreal.ini
+}
+
+md5sums="0f84e1da1d074a4915a9bcfe2319ce84 mailparse-2.1.6.tgz"
+sha256sums="73705197d2b2ee782efa5477eb2a21432f592c2cb05a72c3a037bbe39e02b5cc mailparse-2.1.6.tgz"
+sha512sums="a7337dd2e99a953a55b38c236da95a6bd2950c2bca16fc0ddfec39be8b0ffe01007353fc7b562d0509e0bb1623c3d2b03935d1c98a07dcd9f0b14bb508bce374 mailparse-2.1.6.tgz"