aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5-pear-auth_sasl2
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-28 13:54:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-28 18:38:20 +0200
commit4272e802a1be191657becb739e6a248c1d0411a7 (patch)
treea07a25b7c99d7da326957a88173ba49583cf6b2a /community/php5-pear-auth_sasl2
parent3e272105092cd9804a5a022a188db929ebf440da (diff)
downloadaports-4272e802a1be191657becb739e6a248c1d0411a7.tar.bz2
aports-4272e802a1be191657becb739e6a248c1d0411a7.tar.xz
community/*: move php5 and dependent pkgs from main
There two main reasons for this change: * Active support of PHP 5.x ended on January 2017, security support will end on December 2018. Packages in the main repository should be supported for at least 2 years, this means until first quarter of 2019 for the upcoming v3.6. * php7 and its extensions are currently in the community repository, so we can't use single abuild for both php5-* and php7-* packages (as we do for Python and Lua packages). This change was suggested by @vakartel, approved by @ncopa, @kaniini, and @jirutka.
Diffstat (limited to 'community/php5-pear-auth_sasl2')
-rw-r--r--community/php5-pear-auth_sasl2/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/php5-pear-auth_sasl2/APKBUILD b/community/php5-pear-auth_sasl2/APKBUILD
new file mode 100644
index 0000000000..67f5515c10
--- /dev/null
+++ b/community/php5-pear-auth_sasl2/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+_php=php5
+pkgname=${_php}-pear-auth_sasl2
+_realname=Auth_SASL2
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Abstraction of various SASL mechanism responses"
+url="http://pear.php.net/package/Auth_SASL2"
+arch="noarch"
+license="BSD"
+depends="${_php}-pear"
+makedepends="$depends_dev ${_php}-pear"
+source="$pkgname-$pkgver.tgz::http://download.pear.php.net/package/$_realname-$pkgver.tgz"
+builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/share/pear && \
+ cp -R Auth "$pkgdir"/usr/share/pear || return 1
+}
+
+
+md5sums="1f070b91ec5528bf686284f923c3ac5c php5-pear-auth_sasl2-0.1.0.tgz"
+sha256sums="709f67cd8963b34bc647803aff3be6e935fa212df2944ddea2184f03693d92cc php5-pear-auth_sasl2-0.1.0.tgz"
+sha512sums="a90186155c7ade8c59d9009dfc18a5e19a9a7aa0b0acec45e6cca807162327937e829ebe2537725b316e7fae5352ed7f2be9753f16f962d7581cbc3cf400fb6b php5-pear-auth_sasl2-0.1.0.tgz"