aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5-suhosin
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-11-04 22:35:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-07 15:15:31 +0000
commit51914aa9a07ab9581eb0db317bc0539d82a94baf (patch)
tree10924c3425e1c35c4a00a094a94764625eb1e3a3 /community/php5-suhosin
parent5130c840f0c9f167275e2f6466eb973ba423ca62 (diff)
downloadaports-51914aa9a07ab9581eb0db317bc0539d82a94baf.tar.bz2
aports-51914aa9a07ab9581eb0db317bc0539d82a94baf.tar.xz
community/php5-suhosin: restore to community
* restore php5-suhosin
Diffstat (limited to 'community/php5-suhosin')
-rw-r--r--community/php5-suhosin/APKBUILD45
-rw-r--r--community/php5-suhosin/fix-LOCK-undeclared.patch11
2 files changed, 56 insertions, 0 deletions
diff --git a/community/php5-suhosin/APKBUILD b/community/php5-suhosin/APKBUILD
new file mode 100644
index 0000000000..ec69865c62
--- /dev/null
+++ b/community/php5-suhosin/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+_php=php5
+_realname=suhosin
+pkgname=${_php}-$_realname
+pkgver=0.9.38
+pkgrel=0
+pkgdesc="SUHOSIN - 수호신 - The PHP security extension."
+url="https://www.suhosin.org"
+arch="all"
+license="PHP 3"
+depends=""
+makedepends="${_php}-dev autoconf linux-headers"
+source="https://download.suhosin.org/suhosin-$pkgver.tar.gz
+ fix-LOCK-undeclared.patch
+ "
+builddir="$srcdir/suhosin-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize5
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-php-config=/usr/bin/php-config5
+ make
+}
+
+check() {
+ cd "$builddir"
+ # tests/funcs/crypt_blowfish.phpt failure reported to php
+ # the test asks for an email address due to this failure
+ # make test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ mkdir -p "$pkgdir"/etc/${_php}/conf.d
+ echo "extension=suhosin.so" > "$pkgdir"/etc/${_php}/conf.d/suhosin.ini
+}
+
+sha512sums="cc4eb38b5d6673cc3f2dc395e5a8b5461d3221019ac9849b747b6d5bae423cd5bd01a75b9432414dc7c26c78bab9f2381a5414712a6906a999f3ec9dc77ebc45 suhosin-0.9.38.tar.gz
+8d41d5cf3cf31c086ecc07fa786232df3e821a659dc4ff4e08f9d30f57bce453abcf16345b911b6dba683dd421c2cbe11e0966ef3bb7976d1d6627d8bc66a15e fix-LOCK-undeclared.patch"
diff --git a/community/php5-suhosin/fix-LOCK-undeclared.patch b/community/php5-suhosin/fix-LOCK-undeclared.patch
new file mode 100644
index 0000000000..27b3e7555b
--- /dev/null
+++ b/community/php5-suhosin/fix-LOCK-undeclared.patch
@@ -0,0 +1,11 @@
+--- suhosin-0.9.38/log.c
++++ suhosin-0.9.38/log.c.new
+@@ -27,7 +27,7 @@
+ #include "php.h"
+ #include "php_ini.h"
+ #include "php_suhosin.h"
+-#include <fcntl.h>
++#include <linux/fcntl.h>
+ #include "SAPI.h"
+ #include "ext/standard/datetime.h"
+ #include "ext/standard/flock_compat.h"