aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-08-17 16:15:55 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-17 13:58:04 +0000
commit9d7cc418f0cb3b905d0a707e6b8471b799bdd807 (patch)
treed345b45c14d21276b980a152e854d02dfbaead1e /community/php5
parent426610a910eb000e769072b0f5e8c9daf07037a3 (diff)
downloadaports-9d7cc418f0cb3b905d0a707e6b8471b799bdd807.tar.bz2
aports-9d7cc418f0cb3b905d0a707e6b8471b799bdd807.tar.xz
community/php5: fix dependency
Closes #9119
Diffstat (limited to 'community/php5')
-rw-r--r--community/php5/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/php5/APKBUILD b/community/php5/APKBUILD
index b209767b64..9c0bf5fed3 100644
--- a/community/php5/APKBUILD
+++ b/community/php5/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=php5
pkgver=5.6.37
-pkgrel=0
+pkgrel=1
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -12,7 +12,7 @@ license="PHP-3.0"
depends="$pkgname-cli"
depends_dev="$pkgname-cli pcre-dev"
install="$pkgname.post-upgrade"
-provides="$pkgname-cli php-cli php"
+provides="php"
makedepends="
$depends_dev
apache2-dev
@@ -366,6 +366,7 @@ cgi() {
cli() {
pkgdesc="PHP Command Line Interface (CLI)"
depends="$pkgname-common"
+ provides="php-cli"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/php5 "$subpkgdir"/usr/bin/ || return 1
# provide phpize here instead of -dev due to pecl command
@@ -442,7 +443,7 @@ _mv_ext() {
if [ -n "${2-}" ]; then
depends="${2-}"
fi
- depends="${pkgname} ${depends}"
+ depends="${pkgname}-common ${depends}"
# work around dependency issue
# https://bugs.alpinelinux.org/issues/1848