aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-apcu
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2016-12-08 19:51:12 +0300
committerJakub Jirutka <jakub@jirutka.cz>2016-12-08 19:21:48 +0100
commit40b10f253b1e8e141e7e2898746965b4d3ef124a (patch)
treeefa21012fec6d6d7d0c941527331032dc3ecfbb1 /community/php7-apcu
parent36265c2b70f4f877f4bcdc29997487b661108f85 (diff)
downloadaports-40b10f253b1e8e141e7e2898746965b4d3ef124a.tar.bz2
aports-40b10f253b1e8e141e7e2898746965b4d3ef124a.tar.xz
community/php7-apcu: move from testing
Diffstat (limited to 'community/php7-apcu')
-rw-r--r--community/php7-apcu/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/php7-apcu/APKBUILD b/community/php7-apcu/APKBUILD
new file mode 100644
index 0000000000..d9012d4050
--- /dev/null
+++ b/community/php7-apcu/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=php7-apcu
+_pkgreal=apcu
+# release 5 is php7+
+pkgver=5.1.7
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP extension APC User Cache"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=""
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends pcre-dev"
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+md5sums="7803b58fab6ecfe847ef5b9be6825dea apcu-5.1.7.tgz"
+sha256sums="e71e12985f52d4f4311beedf54540a16b76cf7d2d8b8c1028ec4491d4c0f962c apcu-5.1.7.tgz"
+sha512sums="104e5b1b5dbf1febf4f147775f621d867a5ca60a1ddfe56af5f42f148f7913aa54a31c96baf35c1fd9b3278355d6f14289ffda1601b4a2579430d585f79753b3 apcu-5.1.7.tgz"